Error : HRESULT: 0x800A03EC


i try the export with dynamo, it fits very good :slight_smile:
but i think it fits only with e few doors.

because i have an error to export the parameter of 300Doors

Excel_Test_Türliste_02.dyn (107.1 KB)

Hi Heinrich,

Could you drop your excel file as well?

Sicherung-Türdefinition.xlsx (38.2 KB)
this is the file

Sorry your script is in German language. May be some one else (@Peter_Kompolschek) who can understand german language better can help you.

Don’t know why it doesnt work for you.

i think, it is the problem, when there are 300 doors or more.
I test it with 50 doors, no problem, but with 250 it is a problem.

can i create a split in the export? after 100 lines, next sheet? only one idea…

did you export 1255 doors?

Yes, even filled empty values with 0.00. But it works with empty lists too. Maybe no RAM?

i have a Win 8.1 PRO with Xeon CPU E5-1620v3 @3.50GHz

I dont think that is the problem

I started a new file, but there I reach the error with only 100doors
another Revit-Projekt with 150 doors are OK.

I dont know what there ist??? :frowning:

Maybe dynamo 1.1 can’t handle it. I’ve done this in 1.0

I download 1.0.0, but same Problem

no result and every time same error

Could you post rvt file with doors? Create array or sth

i try it with a new file, seven time I try to export , 5 failed :frowning:

all files i hope you can help me, this is the dyn-file i started

my screencast :

Türen_Export_Dynamo.rvt (1.1 MB)
Tueren.xlsx (51.2 KB)
Excel_Test_Türliste-04.dyn (173.9 KB)

Don’t worry we will help you.

Hi Heinrich,

@Heinrich_Boldt I modified your script. What it does is that it writes all the parameters with their values to excel. After it writes to excel you can then remove the unwanted parameters from excel. Here is the dyn script Excel_Test_Türliste-04(Kulkul).dyn (20.0 KB)


today I´m so busy, i try to look tomorrow, OK?

one option is, that my Excel2016 is broken, after reinstallation on Monday i can start to test next time i`m in the office ( think on fryday next week)

Thank you

I was seeing this when exporting Text Notes with an = symbol in the front of strings

I get this same error with Excel.WriteToFile, but not consistently. Maybe 99% of the time. Even when I test it with data as just a dummy string.