Element.setname works for Family, but doesnt for FamilyInstance

Hello everybody,

I’ve got plenty of Families Instances to be renamed (actually I’d like to completely change their name, but thus far have only gotten as far as renaming parts of it).

I’ve used this video as a guideline for my works- Rename Revit Families With Dynamo - YouTube

I can somewhat successfully change the name of Family (I assume that is Family Type), yet whenever I try yo change a name to FamilyInstance (I assume that this is all instances under Family Type) using Element.setname, nothing happens.

I would much appreciate little help. :slight_smile:

And here is the other workflow, that doesn’t seem to be working for me. :slight_smile:

Its says true, seems worked!

It’s not?

It’s probably because you are trying to change the Type Name (Type Parameter) of an Instance. Get the Family Type, not Instances of the Type and Set the name. Once you’ve done it for the Type once, they’ll all update together.

1 Like

In multiple places it indicated that everything is correct, however, the output hasn’t changed a bit.

Isn’t Type Name (Family Type name) and name of an Instance two independent things? Saying so, because changing the Family Type name, I didn’t see any change in the instance name for that particular family type.

Perhaps I misunderstood? :slight_smile:

Thank you for your reply,

Hello Arvis…think you need the element type…

1 Like

@Arvis please try like @sovitek image.

1 Like

Hello Søren! Greetings from Copenhagen! :slight_smile:

Thank you for your help, it worked!

1 Like

Hi Vijay,
It did, indeed, work.

Have a nice day!

1 Like

Yep… Like I said, Element Type. Glad to see you got it resolved.