Element ID Problem (Dynamo creates a new element when I run it)


#1

I’ve created a Floor.ByOutlineTypeAndLevel, however, the floor is generated every time as a new element. This is a problem because I tag, dimension and use spot elevations on floors. When Dynamo generates a new floor slab it deletes tags and breaks dimensions. I was at a Dynamo users group a few weeks ago and someone mentioned to me that this issue had been solved. I didn’t write it down, therefore I’m unsure if this is a package or a new node. Could someone send me in the right direction? I can’t seem to find any information using Google. Thanks.


Element ID being reused
#2

Share an image or something.


#3

 

 

Dynamo will create a new slab with a new element ID. When the new slab is created it deletes the tag and dimensions.


#4

I was having a similar issue and speaking closely with the Dynamo Team about it. After several tests we still were not sure what the issue was. In my last communication with them via GIThub (https://github.com/DynamoDS/Dynamo/issues/5224), they asked if I had tried my script on a different machine. This ended up working. Try a different machine and see if it works. If that does end up fixing the issue… that’s great (but we still wont know what the problem is). After it ended up working on a different machine, I had our IT department set up a clean OS for me. Never had the problem again. Also, you could post this as an issue to GIThub and reference my issue above.

 

You can also see this previous issue on the dynamo forum (http://dynamobim.org/forums/topic/build-and-rebuild-walls-in-revit/).


#5

Unfortunately, I have replicated this problem a couple of times on two of my computers. My co-worker and I were working on a high rise building so we massed the floor and used Dynamo to build the floors. She and I had the same problem. I went to a user group in San Francisco a few weeks ago and someone mentioned to me that this issue had been resolved with a package. I was trying to see if anyone had heard of this.


#6

Ah, sorry. Should have read more closely. This is most likely a build issue (they would have resolved it in one of their latest releases). Elements not binding correctly is something they would not take lightly, so I imagine they would not have simply released a node for this. What version of Dynamo are you running?


#7

I doubt they can resolve this because it is caused by Revit API limitation. Editing floor boundaries is not possible (well it is, but its really a hack rather then exposed functionality), so the only thing they could implement in Dynamo is to create a new one every time.


#8

Thank you Konrad,

I think this has been the explanation to me. I know that I’ve tried to get the sketch of a filled region and the Revit API can’t get into the edit sketch. I must have dreamed it haha.


#9

Konrad,

Thanks for clearing that up. I assume this is an issue for floor creation in general? Does this go for other revit elements as well?

Thanks in advance.


#10

Just like Danny noted above, this is a Revit wide issue with most of the elements that are sketch based. There is no exposed functionality that allows us to access the sketch lines and just modify them. Of course like I mentioned there are some workarounds for doing that, but they are not the greatest thing in the world. As far as “other” elements go, that should not be an issue. If an element is point, or line based like a wall or piece of furniture you can access its location values and change it. Elements like that, I believe, are not being deleted by Dynamo, but instead just updated.