DynamoGIS - "warning: polycurvees may be branching"

I was making some tests with de DynamoGIS package and trying to follow this article here:

I downloaded a shapefile from my city database and crop it on QGIS. When i tried to use it with de Dynamo package the “Shape.GetAllShapes” function returned that “Polycurves may be branching”

I read another post about the same problem but related to Civil3D. I dont have and i dont know how to use civil 3D
I don’t have to have exact coordinates. I just want to model the buildings.
I could move all shapes to the REVIT zero but i cant read the shapes in REVIT and i dont know how to do it in QGIS.

I tried to move the “survey point” closer to the curves (i can use “Shape.GetShapeAtRecord” to return a single curve) but the error didn’t desapeared and the “survey point” and “origin point” where still listed as 0,0,0 on Dynamo

P.S.: Is there a way to upload the shapefiles here?
P.S.2: The curves are close to X=332388.120, Y=7383892.820, Z = 000,00. I set my REVIT file to meter 000,000

in QGIS- what kind of geometry does your shapefile contain ?
i.e points, lines, polygons, multipolygons etc ?

If you are a new user on this forum- you cannot post attachments, but you can include a link to googledrive, onedrive, dropbox etc

Hello Andrew. Thanks for the reply!
Here is a gooogleedrive link to the files i used.


I think the shapefile contain curve geometries since that is what it returns when i use the “Shape.GetShapeAtRecord” function

There seems to be some invalid geometry in that Shapefile
Using the GetAllShapes node fails without telling you where the problem is, whereas GetShapeAtRecord will show you each feature- I’d assume the problem is with the nulls

Creating a new shapefile (red in the screenshot below) with the same coordinate system as yours seems to work o.k- so the problem must be in the geometry
testshapefile.txt (1.5 KB) (rename to .zip)

Easiest solution is probably to export to DXF in QGIS