Dynamo won't link to Revit

I’ve tried both Dynamo Sandbox and Dynamo Studio, but I can’t get the Dynamo app to recognize Revit. I am using Revit 2018. I’m new to Dynamo, mostly because I haven’t gotten it to connect at all! I haven’t found any resources or forum posts about this. I guess people have mostly moved on to Revit 2020 and up, which has Dynamo built-in…

Point being. When I open Revit 2018 and open a project, then boot up Dynamo, no button shows up in the Manage tab of Revit, and Dynamo acts as if Revit didn’t exist. How do I fix this?

I believe Revit 2018 still comes with Dynamo installed. The Dynamo versions were coupled with the Revit version starting in Revit 2020, so you may need to head to DynamoBuilds for a later version than what comes out of the box with Revit 2018.

I guess I should clarify - When we run Dynamo, you need to think of it as application that runs within another application. Dynamo for Revit, Dynamo for Civil3d, etc. So we dont launch it as a stand-alone program, but from within the host application.

Thanks @AnthonyZ, but the Visual Programming section isn’t even there for me! Here’s what it looks like.

There doesn’t seem to be a way to run Dynamo within Revit from where I’m at.

Looks like you need an installation.

Go to Dynamo Builds and install the latest Revit installer, 2.0.4.

2020-06-30T18:59:48.000Z       221376472       DynamoInstall2.0.4.exe
3 Likes

Thanks @JacobSmall, that worked. I couldn’t find that site before. Anthony linked me to it but I got bogged down thinking that he was saying it was supposed to be pre-installed for Revit 2018. I’m up and running now that I downloaded and ran the installer! That seems very basic but thanks anyway.

1 Like