Dynamo Takes a long time to search for a node in the search bar

Hi guys, I think I found some sort of bug. I was happy to see that revit 2022 comes pre installed with the new version of dynamo. However it is very disconcerting that on a band new, clean script when i tried to search for my first node by typing in the search bar, dynamo still takes forever to search. I cant even type two letters in and have it respond instantaneously like you would expect by typing in to any search bar. This doesnt mean that its taking a long time to search the nodes. This is a problem where it simply can think fast enough to log what I am typing and then do the search. Meaning I have to wait a painfully long 30 sec or so per letter I want to type, and I have to wait another 30sec for each letter after that. Is anyone else having this issue I cant imagine anyone would still be using it if this happened for everyone. Any Idea how to fix this? Please advise. Thanks in advance!

Try with a clean set of packages and see if that loads things faster.

If so:

  1. Remove unnecessary packages
  2. Ensure all packages are distributed locally from the disc
  3. Ensure all packages have minimal to no overlap (ie: you aren’t loading two different versions of Rhythm)
  4. Ensure you’re using the right version of all packages (typically the latest, but there are some notable exceptions - ie: Archi-Lab)

If things still feel slow with packages installed, try pulling out packages in groups to see if it’s a single package (and if so could you replace that one package or reach out to the author to identify the search speed issue).

You could also try utilizing the simple search in the Monocle view extension.

To add to what Jacob said, I find search also gets slow after using some addins - almost like it burns out dynamo a bit. I’ve experienced this for rhino inside and pyrevit, suspect theyre fighting over the dll files.

Great add for my list!

1 Like

Hi Jacob, this is a clean version of Dynamo on a brand new VM so I dont have any packages installed yet. Thats why its so surprising to me.

Very curious… Can you post the Dynamo log? What are the node and package paths set to?

It took me awhile to find the new location of where to go to check the package paths. They are nothing special. See below

here is my About:
How do I export the logs?

I am fairly certain performance improvements to search were in 2.13, not 2.12.

1 Like

What is the most up to date version of dynamo I should be on? and it looks like there is a special installation procedure of some kind? Can I just run the exe? or is it more complicated than that? please advise.

Since the 2020 release the only way to update Dynamo for Revit is to update Revit, so don’t go looking down that route.

Have you tried removing add-ins and installed packages and view extensions? Can you provide the Dynamo Log and Revit Journal so we can see if there is any identified conflict at play?

Sure thing, I did have to install some packages yesterday so I could actually get some work done. But my earliest journal(s) should reflect that I had no packages and that was when the problem was the worst.
See attached.

journal.0008.txt (1.2 MB)
journal.0007.txt (1001.9 KB)
journal.0006.txt (1.6 MB)
journal.0004.txt (3.0 MB)

dynamoLog_e89e34ec-fc37-44ae-8333-df03930f5bf5.txt (47.5 KB)
dynamoLog_795e1f24-4951-4bf5-9e62-0f73ac4bdc1f.txt (5.6 KB)
dynamoLog_32b84d22-872a-411a-bb2a-1c77788fd585.txt (25.6 KB)
dynamoLog_5c2a1457-7a0a-4c03-a645-435617d1e1ed.txt (19.3 KB)
dynamoLog_aa3a797f-5a41-4980-992a-3a8e80434965.txt (6.8 KB)

See if disabling all your Revit add-ins helps. Bluebeam, Evolve Mechanical, and BIMTrack show up in the journal, in addition to a few Autodesk ones (some of which can’t be removed). Conflicting Revit add-ins are triggering a few errors around references which Dynamo uses, so they may be the culprit.

Hi All,

I have a similar issues with Revit 2022.1.3 and Dynamo 2.12.1.

I have tried removing all add-ins and all packages but it did not help.

Happy to start a new topic or give more info here.

1 Like

Is there a reason dynamo is fighting over references from other addins?Is there a way to make it not fight over the references other addins use so it can “play nice” with others? I just dont think that is sustainable, people need other addins for a reason and I hope its possible to make it so we “the end users” dont have to choose between dynamo and other addins. Some of these addins are required by my work, to do my job and installed automatically from my IT department, which i am sure is probably the case for lots of folks.

1 Like