Dynamo Structural analysis Package-Read Analysis

Hi everyone,

I have Revit model+Analytical model, send to Robot, run analysis and the import back the results into Revit. All worked, in fact i can see the results at the RC pile location (as expected).
I’m now trying to extract those results and use them to create schedule.
First thing first i’m having a go with Dynamo and the Structural Analysis Package, I’m just trying to read results from one pile… please see the attached images.
I’m keep getting errors, any help would appreciated!

Thanks all

PS the element i selected in Dynamo is the RC pile

1 Like

May I ask you… If you have already used the build in plug-in for the RVT->RSA og RSA->RVT.
Meaning that you have your desired results on your pile, why try to grab the info from RSA when it is much more simple to do in RVT? :slight_smile:

I’m not saying it is not possible, but to better help you I prefer to understand your issue :slight_smile:

Likewise, if you insist on wanting the info from RSA please let us know what the yellow error says? :slight_smile:

Hi Jonathan,
Thanks for your reply. Yes i did import the result in Revit using Robot structural analysis link (see image below) and it worked, in fact that i can visualise the results. Unfortunately i didn’t find a way to access them for scheduling, that’s why i’m trying with Dynamo (in Revit).
Do you know a way around this?.. what i need are the results of the reactions

In that case I would not advice you to pull them from RSA but rather use the results from RVT… :slight_smile:

Have you looked at the pile structural column elements and the analytical model? :slight_smile:

If you still encounter problems please upload a sample RVT file containing the situation you’re facing :slight_smile:

Basically i can’t find where this results are stored in Revit and how i can use them to schedule.
Yep, i did look into the analytical foundation and canould find trace of them.
I’m uploading the model as you suggested, it’s Revit2017, the results should be embedded in the result manager/explorer.
Thank you

Here the link

https://we.tl/t-eLdUiWsPyE

Seems first order of business would be to get your models to correspond, i have not seen your analysis model but it seems that there is inconsistensy in the columns of your RSA and RVT file (analytical columns)…

image

Thanks again Jonathan. There are actually no columns, just foundations. Here another link to the Revit file with the updated results. :slight_smile:
Best
https://we.tl/t-DCiDSWayFq

It might be a version thing…

I’m on 2018 and when exporting to RSA and calculating and exporting back to RVT no reactions can be transfered :slight_smile:
image

I’m sorry, but I cannot see the reaction data available anywhere in the .rvt file :slight_smile: