Dynamo Sandbox without Revit - current status?

i have tried the following sanbox

Stable release:
DynamoCoreRuntime2.1.0.
DynamoCoreRuntime_2.2.1.5175

Daily builds
DynamoCoreRuntime_2.3.0.4387
DynamoCoreRuntime_2.4.0.5617

All unziped with “7-Zip” app.

i downloaded and installed Revit but did not activate it, then it worked for me.

Marcel

1 Like

I have heard that you need to have at least one autodesk product installed to be able to utilise the geometric elements of dynamo sandbox. This could be revit or autocad as a example

My sys-3 has Revit 2014, Autocad 2013 from adsk installed, but still dynamo sandbox not working properly.

I copied the “LibG.Protointerface.dll” from Libg_202** folder to dynamo coreruntime_2.2.1.5175 folder (where i unzip the app).

Now the warning changed as below.

Pretty sure the references that Dynamo uses have changed in the six years since 2014 came out. I think you will need something 2018 or newer.

Hello Akuc007,

Dynamo Sandbox will run stand-alone without any Autodesk software if you don’t want to use Geometry. This blog post explains a little more about Sandbox.

If you want to use Geometry in Dynamo Sandbox (Which I believe is what you are asking) you will need to have a recent version of Revit, FormIt or Civil 3D. We typically support the most recent version and two versions backwards.

If you are looking for Geometry inside of Sandbox then please go to your manage.autodesk.com tab and install one of these applications :slight_smile:

Hi salamour,

Thank you. now i understood recent version of adsk app needed for Dynamo to support shapes (geometry).

Once again thank you.

1 Like

Hi Solamour

I would like just to ask something. where I should install the Dynamo Build in order to have also the Geometry Enviroment? I have Formit and Dynamo Studio installed in my computer. Thank You in advance for your Help

Hello @J.Rymer - If you are talking about Dynamo Sandbox it should automatically pick up the Geometry from FormIt :slight_smile: Feel free to unzip it anywhere you wish!

Thank You for your answer @solamour: Regretfully it doesn’t. I don´t know if I did something wrong at the Unzip process. I got the same messages in previous comments from the other Colleagues here. I can open the Dynamo Tool in Formit but that version is the Build 2.1. Any Help ? I would really appreciate it and thank you in advance

Which version of of Sandbox are you trying to install? Are you installing from dynamobuilds.com - as shown below?

yes and I was installing the Build 2.41 and the 2.40

1 Like

Warning: Point.ByCoordinates failed.
The type initializer for “Autodesk.LibG.LibGPINVOKE” has caused an exception.

I received this message

1 Like

I am following up with the developers on this one :slight_smile: Will get back to you when I have answers!

1 Like

Hello @J.Rymer,

We can use the CLI to point to the location of data inside FormIt as a workaround to what should be happening automatically as per this wiki entry: https://github.com/DynamoDS/Dynamo/wiki/Dynamo-Command-Line-Interface

Can you try the following steps please and let me know if it works:

  1. Open up your Command Prompt
  2. Find the location of where you unzipped Dynamo Sandbox. e.g. C:\Documents\Dynamo Sandbox Versions\DynamoCoreRuntime_2.4.0
  3. Find the location of your FormIt route directory. e.g. C:\Program Files\Autodesk\FormIt
  4. Type into the command prompt: C:\Documents\Dynamo Sandbox Versions\DynamoCoreRuntime_2.4.0\DynamoCLI.exe -gp "location of FormIt route directory here"

Have a go with this and tell me if it helps :slight_smile: We are in this case using the CLI (Command Line Interface, or Dynamo without UI) to access a special call to point things to the right location!

In theory you should be able to open up the same Dynamo version after this and have Geometry working.

2 Likes

Theres a few corrections here to use this flag correctly.

  1. This flag only exists on 2.5 and master builds - it won’t work in 2.4
  2. while you can use this flag on the CLI - you can also start DynamoSanbox.exe with it. (which sounds like what you want).

ie DynamoSandbox.exe -gp "pathToFormitASM"

2 Likes

Is this still true? Is there any way to use geometry inside Dynamo without having one of those programs installed?

Yes.

Dynamo Studio would do this. However you are capped at 1.3. For newer builds there is no solution without the additional programs at this time.

2 Likes

Hi solamour,

I tried this Method with the Version 2.41 and as @Michael_Kirschner2 described it should just work for the Version 2.5 and Master Builds. Now the question would be which one from all the 2.5xxxx Versions?

Hi Michael

I just wrote a message to @solamour about your explanation. I tried to apply it on a 2.5 version but it didn’t really work. Maybe I am not downloading the correct version. Any Help ? I will really appreciate it.