Dynamo Player Icon Greyed out

Hi everyone,

I tried to set the default folder in the Dynamo Player Tool but something strange happened.
From then I can’t open the Dynamo Player and when I try to use the script that I created I obtain an error.

The Dynamo player button is greyed out.

I uninstall and reinstall Dynamo.

Thank you in advance.

May anyone help me?

I removed and reinstall dynamo but the problem remains unsolved.
I am a bit desperate I can’t use my dynamo scripts at all. :cry:

Thank you.

Something’s not clear in your post. You say you can’t open Dynamo Player and it’s grayed out. Then you say you try to use the script that you created and obtain the error in the screenshot.

How did you try to use the script if the button is grayed out?

The Dynamo Player button grays out when I click it.
The Dynamo button is not grayed out but since I have this probleme I can’t use my dynamo scripts. I obtain the error like I showed in the first picture.

The ‘goes grey’ indicates that the player is launching. Hit alt+tab to see if you can find the dynamo player listed in the open programs, and tab into that window if it’s listed.

If it doesn’t show up after you tab into t, hit alt+space, then hit m, tap an arrow key, and then move your mouse to pull it back onto your desktop.


Hi Jacob,
I tryed what you proposed but there is nothing behind the windows. I made a little video too.https://global.discourse-cdn.com/business6/uploads/dynamobim/original/3X/b/5/b51d8c51358dd6e9c12f07753c73d738beb56070.mp4

What Jacob means is sometimes the window can open outside the boundaries of the screen. So you can’t see it if you Alt Tabbed or minimized your Revit window.

From your video, I can see that after you opened Dynamo Player, you clicked again, making Revit the active window, which defeated the purpose of using alt+space later.

Try again, this time pressing alt+space immediately after you launch Dynamo Player, click move in the menu that pops out, then tap some arrow keys until the player window appears on the screen.

Sorry but I think I didn’t understand well. When I tap ALT+space not windows with (move) options appears.
I made a little video again.https://global.discourse-cdn.com/business6/uploads/dynamobim/original/3X/e/1/e1df850ce87e6e7630b8e5f6462ac435e33a3abb.mp4

This is somewhat moving away from Dynamo and towards general Windows issues…

The problem is we haven’t yet even gotten to a point to be sure this is the issue.

@JC.Moreno Try clicking on “Restaurer” before you click on “Déplacer”.

I hope I did properly this time. :grinning

Try and wait for 1 minute after clicking your dynamo player icon… then press the “Alt+Space” and click “Move” and then do not touch your mouse further, then use your arrow-keys to move around the window until it hopefully comes into view.
Tried showing it with a small gif:

I tried again, this time I waited 1 minute or more. But I had the same thing.

I tried again, this time I waited 1 minute or more. But I had the same thing.

I have the same problem!!

me too
any solution ?

Hold down alt+tab and take a screenshot of what shows up.

Another post seems resolved same issue. Please have a try for the dynamo player cache folder:
“if the player windows is off-screen somehow you can try to delete cache folder located here : C:\Users–youruser–\AppData\Local\dynamoplayer-2 If that’s the issue it will reset player window position to default.”

Refer: Dynamo Player ghost

For 2nd possible reason, it maybe relative with the proxy setting.
Windows system: Open ‘Proxy setting’, check if ‘proxy server’ is set.
If proxy server is set to on, and check the option ‘Don’t use the proxy server for local address’, then relaunch C3D and try ‘DynamoPlayer’ again.
Or just close the proxy and relaunch C3D and DynamoPlayer.

Thanks for new update.