Dynamo not recognizing that link moved

Hello all, im a newbie and Im messing around with OOTB revit sample models to see if I can get the Does.Intersect node to make any sensible output for me. The first time I ran it I got no intersections with rooms and air terminals so I moved the architectural model entirely and even rotated it to make sure that it was in the path of the air terminals but dynamo refuses to update the element.geometry to the new location. I mean what gives? i tried saving my work but that had no effect either.

What are you using to fetch the room elements?

Hello, Dimitar, here are the fetching nodes that I am using (see below) Dynamo is acting really strange, because even after I deleted the link entirely reloaded it again, then moved it again, and rotated it again, it STILL SHOWS UP IN EXACTLY THE SAME SPOT AS BEFORE! I mean how is that even possible?? Please advise.

That’s because those are custom nodes and unfortunately they can not update automatically without some kind of a manual trigger. You’ll have to disconnect one of the inputs, execute the graph, re-connect the input and re-execute the graph…

Alternatively you could try Spring Nodes’ “Collector.LinkedInstanceElements” node and use a Boolean node as a trigger:

I thought you were on to something there but neither suggestion worked, i tried both. Look at my graph: I even tried deleting each node and replacing them. Still no luck

dynamo has to have some sort of memory bank somewhere that its not letting me access/manipulate.

I’m not sure why the geometry is not updating for you, I can not replicate that.

The position of the linked geometry is aligned according to the linked file’s coordinate system. If the host document does not share the same origin or if you’ve moved the linked instance, you’ll need to relocate the linked geometry with the “Geometry.Transform” node. You can use the coordinate system provided by the “Collector.LinkedInstanceElements” node.