Dynamo not able to Read Excel

I have tried multiple ways to get my Dynamo to read an Excel file, so far none of them have worked. Our Excel is 2007, so that might be an issue. At my last job I did a lot of Excel-Dynamo-Revit read/write, and it was very helpful. But I have been stuck on this for quite some time now. What am I doing wrong?

Here are three examples of how I have been trying to read Excel:

Have you tried downloading a trial of the most recent version of Excel to see if the old version is causing the issue? Alternatively you can save your spreadsheets as .CSV files, although that’s an extra step and may not be ideal.

2 Likes

2007 is the issue. CSV workaround is likely your best bet, but a monthly subscription to MS Office with the current updates and security patches will likely cost you less then doing the import export run-around.

1 Like

@cgartland unfortunately this is on my work computer, so I cannot download the most recent version :frowning:. I will give the .csv a shot

@JacobSmall Good to know that the Excel 2007 is confirmed as the issue.

Thanks!

Might want to let the bosses know it’s time to update.

Not getting security fixes isn’t something to brush off.

1 Like