Dynamo missing in civil 3D 2022 after reinstall

not quite sure if this is the correct forum to ask but maybe someone can help me with this:
On my PC dynamo does not get installed in Civil 2022 (no dynamo.dll in C3D folder, no Dynamo folder under C3D in app data, no visual programming tab under manage). I had no idea why this was happening, because on a coworker machine it was working using the same installer. However i had to reinstall Civil 2022 on that PC and now dynamo is missing as well. I had to reinstall on my pc a while back, so my guess is, that dynamo breaks if your reinstall Civil 2022.
Can anyone confirm this or even propose a fix?
Thanks in advance

1 Like

Best to reach out to my colleagues in Autodesk Support on this one. This way they can attempt to document the root cause to prevent future issues in other releases and produce instructions on keeping the document working.

My guess is the reinstall process wasn’t complete, and you will need to do a complete uninstall, followed by a full install to get it working.

Thanks for the quick replies but as i had written above there is no AeccDynamo.dll to netload in C:\Program Files\Autodesk\AutoCAD 2022\C3D on the Computers where Dynamo broke.
The dynamo folder under C:\Users\User\AppData\Roaming\Autodesk\C3D 2022 is missing as well.
The update to 2022.1 does not change this.
I will reach out to autokdesk support, if anybody has the same issue i will post the solution here in the future.
Thank you guys!


Sorry, I replied too quickly without fully reading your post.

This happened to me when I installed 2021.1, all Dynamo folders and files where gone. I can confirm this can happen.

In case anyone is having this issue, i found the following solution:

This worked on 3 Computers so far, so i guess this solves the issue.


Be careful. After this procedure it is not possible to import user subassemblies into the tool palette in my Civil 3D (Czech installation).

@Drbohlav that sounds like the issue that was fixed in the 2022.1.1 update. Not sure it’s related to Dynamo…


Solved my problem.

I followed the solution here, and it works for me,
1- run the NETLOAD command and add the file AcDynamo.dll
path: “C:\Program Files\Autodesk\AutoCAD 2022\C3D\Dynamo”
2- run this command: AECCLAUNCHDYNAMO

hope this solve the problem for all