Dynamo closes if ironpython

Hey there,

This monday my dynamo started having problems in exclusivly Revit 23 dynamo scripts containing ironpython2.7.
Every time i start a script containing such a node an error message occurs and dynamo instantly closes. If i open those scripts in Revit 22 and on my collegues computer in RVT23, they work just fine.

I tried to copy the installed packages, even “DynamoIronPython2.7”. As using the same didnt work either, i went with using the newest revit 23 versions.

I have the recent Revit update installed. Dynamo Core and Dynamo Revit


When i change the python scripts in an older Revit to CPython3 they work again. Problem is i have multiple complex scripts and packages where adapting the code takes time i dont really have right now ;).

I have Generative Design installed if that contributes.

Thank You for all your help

Can you post the Dynamo log from a crashed session, and a corresponding Revit journal?

If i start a script in which an ironpython script, so if it has a python node, the script brings an error when oppening, doesnt load Code Blocks and sets all nodes atop of each other. When i then close dynamo this error comes:
Crash-Report.txt (61.7 KB)
journal.0237.txt (2.3 MB)

for example if i open a package with iron python it closes instantly if there is a ironpython node.

Thank you

This is helpful, but do you have the Dynamo log from the crashed session associated with the journal? Kind of need the full set.

One thing you can try in the meantime: disable all Revit add-ins to see if that resolves the issue.

Uhm, those are now all from 13:32 o clock and therefore should be from the same instance.

CrashReportIronPython.txt (49.3 KB)
journal.0238.txt (304.6 KB)
journal.0237.txt (4.0 MB)

there is also a worker journal i had to copie to be able to paste here:
journal238_worker.txt (26.8 KB)

I hope that this helps, i know those “buts” :sweat_smile:.

i tried disabling the add ins beside DiRoots, didnt work sadly. Will check if disabling DiRoots helps.

Thank You again for your effort.

I am seeing DiRoots, Metamorphosis, and a handful of Autodesk post install tools as well. Turn them all off if you can so we can rule out as many possible conflicts as possible.

After that, give the system a restart, attempt to recreate teh issue, and it it crashes force quit anything left open and grab

  • The Dynamo log from this folder: %appdata%\Dynamo\Dynamo Revit\version\Logs
  • The Revit journal from this folder: C:\Users\smallj\AppData\Local\Autodesk\Revit\Autodesk Revit 2023\Journals

Be sure the two files associate by checking the time stamps.

Turned them of. Error still occured.

Here is the log from %appdata%:
dynamoLog_48174b17-cda8-4c86-9429-0788f1a4fb97.txt (37.4 KB)
Here the journal:
journal.0241.txt (259.3 KB)

There are severall log vesion with similar time stamps, one or two minutes earlier. I hope those are the correct ones. I apologize if this is not so.

Next thought is that something on the server (N drive) is causing some issues; Relaunch Dynamo and make sure that all pacakges are pointing at the C drive. If it still fails from there we move onto creating a support ticket via Manage.Autodesk.com if nothing new comes into the log or journal.

what are the “details” (stack trace) in the crash dialog?

The Crash Dialog is pretty much what i posted in my first comment as Crash Report. Here is a recent Version.

Details-CrashDialog.txt (45.4 KB)

So i checked the installed path for every installed package, they are all poniting towards C drive.
The custom blocks are a different story, but they arent loaded into every script. Therefore i deleted every N drive path where they get loaded and restarted dynamo → Same thing sadly.

dynamoLog_a84b69c8-a75f-4649-aa63-84b9e8df26ae.txt (27.4 KB)

journal.0243.txt (583.5 KB)

So support ticket it is i guess.

fun fact: all script work when run by dynamo player (only without being opened in dynamo again). Still a major problem.