Dynamo & ARM Processors

Hi All,

New laptop (Surface Pro X with a SQ1 ARM Processor running 64-bit Windows) - Which I’m trying to install Dynamo on… but appears not to be working and I just get the error below! Assuming like many software providers that ARM isn’t supported yet?

Or if anyone knows of any work arounds/pointers to a version which is supported?

Cheers!

it looks like you have not unblocked the dynamo sandbox - zip - did you checkout the instructions in the wiki? (try using 7zip)

3 Likes

Yepp unblocked and originally extracted with the default windows - didn’t work. Just repeated with 7zip and no luck there either.

I had the same issue, the problem by me was that I already had Revit installed with the dynamo sandbox.
If you already have Revit installed go to C:\Program Files\Dynamo\Dynamo Core\ (version) and select Dynamo Sandbox

So I’ve popped Sandbox into that location - I don’t have Revit installed on this machine - but still stumbling along with the same error.

It’s not too do with how an ARM chip works vs Intel?

You have updated to Windows 11 ?

Tried it on Windows 10, although just installing 11 now

I don’t think it has to do with ARM chips, but it could - if you are on an ARM chip then your version of windows should support x64 emulation. I’m not sure how well it works though, but Dynamo is actually running here.

What version of sandbox is this and where did you download it?

well, I guess I was thinking of the preview…

sounds like windows 11 may give you a better shot. I believe .net arm native support is rather recent (.net5/6)- though it does exist, we do not have a build of dynamo core for it as dynamo itself is still using .net framework 4.8.

1 Like

Thanks Michael,

Sandbox downloaded from this website. I’ve just run through all the 2.X.X versions, which only 2.1.0, 2.4.0 & 2.6.0 actually open. Two errors are displayed in the console:

  • Library UI missing - LibraryUI: Could not load file or assembly ‘CefSharp, Version=65.0.1.0, Culture=neutral, PublicKeyToken=40c4b6fc221f4138’ or one of its dependencies. An attempt was made to load a program with an incorrect format.
  • No background preview is available (Unable to find [sharpdx_direct3d11_effects_x86.dll] in the PATH)

Hence has me thinking it’s the ARM side of things causing the issues.

indeed, both of these features (and geometry) have native dependencies. Though there are other requirements for them as well.

  • Newer versions of dynamo require directx 11, these older versions will require dx 10.
  • CefSharp will require the visual studio cpp redistributable (mentioned in the wiki linked in your original screenshot)

Forgot about DirectX install :man_facepalming:- So graphics working.

I already had the VS Cpp installed - reinstalled it anyway - but this is still popping up missing & library UI is blank. 2.6.0 will open, but 2.12.0 still shows the original pop-up.

At least I’ve got a version working, will be nice to have the library but isn’t essential for me :slightly_smiling_face:

@Dan.Cornick have you tried the latest daily builds as well?

Sure, I’ll try the daily builds. But I think it’s more relating to ARM vs Intel. Using some of nodes, errors appear for missing dll’s - yet the VS is installed: C++ 2015 Redistributable (x86) - 14.0.24215 & C++ 2022 Redistributable (Arm64) - 14.30.30704