Dynamo 1.0 not installing

This bizarre. I install Dynamo 1.0.0. It runs through the install process. But when I look in Revit 2016 there is no Dynamo tab. I look in Appdata/revit/addins folder, no .addin file for Dynamo. I look in Program Files folder and there is a Dynamo folder but it is empty.

I redownloaded the install file and tried to install it a couple more times. Same result.
Other add-ins and exe installed fine (e.g. Model Checker).

Has anyone had this problem?

Uninstall from control panel then restart your PC.
Try installing again. Are you installing in office PC or your own PC? Make sure you install with administration rights.

And also check in manage tab. May be it is there.

Dynamo is not in Programs and Features in Control Panel. It hasn’t installed at all.
The weird thing is I would have though if Dynamo was having a problem installing it would say something during the install.

Got IT admin to install it. Seems I didn’t have enough privileges to write to the unpacking folder in User/Appdata/temp.
Not Dynamo’s fault but shouldn’t it have said something?