Data Shapes MultiInputForm ++ Not working with Dyno 0.6.1 for Dynamo 1.2.1

Hi all,

I have a script that works perfectly well within Dynamo, but for whatever reason when I try to run it from Dyno it’s playing up and does not open the data shapes Mulitinput form.

Please see snippet of the code below. It could possibly be a problem with Dyno as I’m pretty sure it was working previous versions.

As always, your comments will be greatly appreciated


Hi James,

where’s the file path in the UI.FilePath Data node?


The “File Directory” is one of the inputs of the form.


I assumed the Default Path input would’ve expected an input - perhaps not, I guess!

If you de-list.create your inputs and just connect the filepath / dropdown data parts into the MultipleInputForm++ Inputs node individually do they work?

Have you refreshed the node using the boolean toggle?

The code itself work fine when I click run within Dynamo, it just doesn’t work via the dyno button on the ribbon. Is there a way to auto refresh the Boolean toggle, maybe that would help.

Otherwise I might have to uninstall Dyno.


Hi @James_Washbourne

I just tried with dynamo 0.6.1 and Dynamo 1.3 and it seems to be working fine.
Does it work when you launch the script through the dyno browser?

Also, it’s better to save your script in manual mode (that info is saved in the .dyn) .


The script does run but it doesn’t open the input box. I just get a blank excel sheet titled “Set Toogle to True” even though is it already.

I might change the versions as you have there and give that a go.



I’ve updated the dyno and dynamo version as you have above and it still doesn’t work.

I’ve also updated the datashapes package for dynamo 1.3 and now I have an error and the input box doesn’t appear. Does the new node support file path data?


There’s a little extra thing to do on existing nodes after you update the package.
you need to right click on the new inputs and activate the default values :

This goes for UI.MultipleInputForm++ and all the “ Data” nodes. You’ll know that all default values have been acivated when the title bar of the nodes become black instead of light grey.


Thanks for this, the code is back working within Dynamo. But I’m still experiencing problems with dyno not running it properly. So I’ve uninstalled Dyno and installed it again, clicked on the button and I get this error msg.

Any idea what’s causing this?


Maybe @Aleksey_Lobanov can help understand what’s going on


Could you please send me your dpr. file for the button. There’s obviously an issue with my dpr file.

Here it is.
Did you make sure to set the ecoding to UTF-8 ?

buttons.txt (78 Bytes)


Sorry I meant the dpr.file for the dyn. Could you send that over please.

Sorry for any inconvenience caused.

Thank you