Data.ImportExcel operation failed

Hi David,

I had the same issue and I could resolve it by using normal xls file instead of xlsx.
I hope it helps you too.

I had the same issue and it worked by repairing the Office

Hi All,

Did we ever find a concrete solution to this issue.
I am now facing the same issue on my newer machines :frowning:

This did help for me, thanks

I had the same error as @Michael_Coffey. What helped me was Repairing Excel. So far this issues has not reapeared.

1 Like

Thanks to everyone!
“REPAIRING OFFICE” did the job for me.
I was having the same issue , was working on it since last ten consecutive hours. I was seeing that same error faced by many people since 2017 or before and still the developer or unable to give the description of error in dynamo so that one should do thay needs to be done instead of wasting time just like MYSELF!

1 Like

Uninstalling and reinstalling 365 did the job for me.

2 Likes

Just got this error and just like the rest repairing Excel did the trick! (I could still write to CSV and to XML, just not Excel).

This worked for me:

1 Like

Hi there, I’ve been researching around and I foud that my Microsoft Office Apps was in x32 version, and my operation system was in 64. When I reinstalled office with the x 64 version the script worked ok. So, in order to verify if you office is in x32 or 64, you can go to any office application then go to account and next go to About.

Just out of curiosity:

The import of data from excel does not work on my machine, if the excel-file is in a folder that is synched by microsoft’s OneDrive. I always need to pause the synchronisation of OneDrive-Folders before I start my dynamo-script. Does anybody else have this problem? I mean it’s easily solved by pausing OneDrive, but still it’s annoying.

Does it work if you use Bumblebee for read and write ?

Never tried, as we are not allowed to use packages in our company. :confused:

1 Like

allright if so you could see how Konrad has do it and make your own node as it written in python i think;) anyway bumblebee seems to work without issues at least for me :wink:

Unfortunately its not written in python, but I maybe implement a python node, which checks if OneDrive is running and if so kills it via os.system("taskkill /f /im “killthisprogramm.exe”) before reading the excel file.

Killing onedrive is a bad idea unless you restart it when you’re done. This is because a LOT of Microsoft’s tools rely on that running to ensure things don’t fall out of sync. You might be able to circumvent the inevitable “oh I was editing that word doc and forgot that it wasn’t syncing and you didn’t even get to notice I was in it” version conflict by copying the file to another location (say the user’s active temp directory), update the data in that file, overwrite the file in the onedrive directory with the new file version, and remove the temp file.

2 Likes

very strange both read and write is written in python in my version I use that version there fit 2022

Sorry, I meant that it’s not available in the github repository as python code.

arhh ok

I know, but at the moment I’m already pausing the synchronisation everytime a script needs to load an excel-file…So:

The files on my OneDrive are only used by me, as I use OneDrive only as my backup-folder. That Problem was not always there, maybe OneDrive had an update which caused these issues.

FYI:
I am still using Revit 2019 :sweat_smile: