Cutting Walls with Solids doesn't work

Hello,

I am trying to cut the Walls (grey) in the below picture according to the Mass (transparent).

This is my Dynamo graph.


This is the result. The orange is the void family instance.

Notice that the wall has not been cut.

Things I’ve done/tried:

  • Made sure that each family type was created with a unique name so it wouldn’t be overwritten
  • Made the Solid a little bit bigger/smaller than the wall (notice the Geometry.Scale node)
  • Tried making the family instances hosted by the Wall
  • Changed the VoidByGeometry node to a regular FamilyType.ByGeometry node
  • Changed the lacing of the CutGeometry node
  • Created the family types and then placing them as instances in two seperate graphs (so no transaction/regeneration issues)
  • Looked at the other forum posts:

What can I do to fix this?

Hello,

Can you model it as a generic model void? We have similar topic with slanted Walls. This works very well.

KR

Andreas

Do you mean modelling the Mass as a generic model void?

If so, then ufortunately no. I am interested in the geometry contained within the Mass, not outside it.

2022-05-02_09h14_12

… i am not sure if “just” mass is able to cut walls. You could host walls on it and cut out than…

we use voids for cutting Systemfamilies

@Draxl_Andreas Thanks for your reply.

However, I fixed it myself:

Apparently the associated Family Parameter “Cuts with Voids When Loaded” is not checked off by default when creating the Void Generic Model in Dynamo (which is what I assumed).

image

To fix it, I simply set the parameter to 1 before placing the instances and using them to cut the elements.

I hope this can help other people with the same issue (since this hasn’t been described in any of the other forum threads).

1 Like