Custom Node Results differ from Nodes in Graph

I made a custom node from nodes that work in my graph, but the custom node does return the same results.

It places everything inside lists. I’ve tried changing different lacing but it makes no difference.

I also noticed this on a Clockwork package node (String.FindRegularExpression)- it returned lists instead of bool.

It these some setting I’m missing?











Hi Anthony,

Could you try deleting the input classifications? ( the " : Element" and " : string"). Those might be overriding the lacing and forcing the node to process the input on an item by item basis, instead of as a list.

When I delete the input nodes there are no plugs in the node.

I’ve tried deleting the output nodes as well and it makes no difference.



No no, don’t delete the input nodes, just the colon and the text after it. :slight_smile:
So that “element : Element” becomes just “element”. Do that for all the input nodes and see if it works as expected.


Spot on Dimitar, thanks a million. Removing the datatype works.

A word of caution, Dynamo automatically added the Input nodes with datatypes when I saved the nodes off as a custom node.
It seems you need to manually fix it.



Little documentation exists regarding this issue exists, with the exception of the two or three specific cases. I wonder how many people are dealing -> not dealing with this issue; it is obscure.

1 Like