Custom Node Not Loading After Closing and Re-opening Dynamo Session

Hi All,

The issue I’m having is similar to that posted here:

https://forum.dynamobim.com/t/custom-nodes-not-loading/2764

Unfortunately I’ve attempted the suggestions proposed in that thread and still can’t find a solution.

For those who would like more detailed write up of the issue:

I came up with a little script to get a view template by it’s name. A screenshot of the .dyn file showing the workflow is below:

Once satisfied with the functionality of the script, I select all, right-click on the canvas, and select ‘Create Custom Node’. This prompts the following dialogue box:

I enter in the custom node properties as per the above and click OK, after which 3 visible changes occur:

  1. DeniNodes appears in the list of third-party packages within the library on the left hand side of the screen.
  2. All nodes previously contained in my .dyn file have been replaced with the custom node ‘ViewTemplateByName’.
  3. The custom node ‘ViewTemplateByName’ .dyf file is opened in another tab.


At this point, I format the .dyf file as per the below:
4)%20Cleaned%20Node%20-%20Ready%20to%20Save

With the node now ready to save, I click the X icon to close the .dyf file and am prompted to save the .dyf file. I save the .dyf file to the path below:


Please note that this path is the default path where my third-party packages are saved and where Dynamo looks to load nodes. This is set using the Manage Node and Package Paths dialogue box (Settings–>Manage Node and Package Paths) as shown below:
7)%20Manage%20Node%20%26%20Package%20Paths%20Properties

Once I click Save I return to my original .dyn file where I test my custom node at it works as intended, as shown below:

The node works perfectly fine until I close my dynamo session. When I reopen the script, my node is red and returns the following error message “Error: Custom node definition is not loaded!”, as shown below:


Additionally, one can see that ‘package directory’ (for lack of a better name) DeniNodes which was previously added to the list of third-party packages within the library on the left hand side of the screen, has now disappeared. All other third-party packages remain.

Could anybody please let me know where I am going wrong with this procedure?

Thank you in advance for your help!

Try saving to the C drive instead. Would narrow down if it’s a network blocking issue.

1 Like

Thanks. I’ll try that first thing in the morning. Is there a specific folder this should be saved to?

Once I save the .dyf to the location on the C drive do I add that path to the ’Manage Node and Package Paths’ list, so that Dynamo knows where to look?

Thanks

I’d go with the default location, and remove the L drive from the paths for now.

1 Like

I don’t think nodes will load from nested folders - try adding the deniNodes folder to set of paths directly.

2 Likes

Thanks Jacob I’ll give this a go and let you know how I go.

Thanks Michael I’ll test this out when I get back to my pc and let you know how I go. Appreciate the help.

Hi @JacobSmall

I tried copying the .dyf file to C:\Users<User>\AppData\Roaming\Dynamo\Dynamo Revit\2.0 with no luck.

I then tried copying the Deninodes folder containing the custom node to C:\Users\\AppData\Roaming\Dynamo\Dynamo Revit\2.0\packages
When I did this Deninodes showed up in the third-party packages list again, but alas, when I restart Dynamo it disappears again.

Both paths were added to the Manage Node and Package Paths directory.

Hi @Michael_Kirschner2

It worked! Thank you for your solution. I thought I was missing something simple…just didn’t know what. I’ll keep this in mind for the future.

Thanks again!

2 Likes