Custom node - custom definition node is not loaded


I’ve been more similar posts but I haven’t been able to find the solution to solve the issue.
I created several custom nodes for my own use and I saved them in my personal folder (.dyf). Everything seemed to work ok yesterday when I created them, but I’ve just tried to open the workflow containing these nodes and all of them are saying they are not loaded.
I’ve tried many things but having unsuccessful results:

  • I’ve seen in other post the problem may be as I should have maintained the original folder to save these nodes, I’ve tried to copy them there but still not appearing when I open the workflow.
  • Also tried to import a library but the format is not compatible with the .dyf
  • Finally, I’ve tried just to copy the nodes sequence inside one my custom node to copy in the original workflow and try to create it again but it seems like I cannot copy-paste with the custom node.

It is very important to find a solution for this as I spent a lot of time making these nodes and it would be a waste if I cannot solve this now.


Hi :slight_smile:

Have you already read this ?


Thanks a lot for that. I hadn’t read it before so I didn’t know that nodes where able to be locally published.
I’ve just tried to publish one of my custom node locally but then I have tried to import a library in the global workflow and unfortunately any of the format seems to be compatible again.
Would you have any idea about that?

To be honest, I only did this once, six months ago, using this tutorial, so I have no memory at all of the process :sweat_smile:

Try opening the dyn, then open each of the dyf files individually. This should put them into your library.