Create space by phase

hey dyno’s,

I am creating spaces with data which i am getting from rooms which are in a linked model, i collect all the data like room number, name & phases created in, now i am using a node from orchid called spatialelement.createspace which allows me to create spaces in specific phases, i am inputting the correct phases as well, but as a result spaces which are created by script are made in the current phase not in the order which i inputted as a phase, kindly see attached images for reference.

Might be an issue with the orchid node. Best to raise via the project’s GitHub.

thanks jacob for quick answer, is there any other way of doing this?

You could try setting the phase created after placing it with an Element.SetParameterValueByName node.

But after making the space phase created parameter is read only

Have you tried running with the lacing set to Auto or Shortest? You might even trying forcing it by running all the inputs @L1.

1 Like

No matter whatever lacing is there or which level i run the inputs it is creating spaces in current phase not in what i input

It has taken some effort and I pretty much had to break all the rules for how things should be done, but… I have this working to some degree in Revit 2022. I still need to edit it a bit further to allow iterating over a list of points for the space (as I’m guessing that will be the next ask), but assuming that you haven’t gotten any help from the Orchid GitHub page then that is a task I’ll try to fit in tomorrow or next week when I get some down time.

@JacobSmall I tried to solve that without any luck, based on some searches, the RevitAPI method itself does not work, for the node by Orchid, even if nothing linked to the phase input it will work picking up the Active view phase.

Using Python, the same happened, I tried to iterate over changing the active view phase so the space method (level, UV) would pick up the phase without any luck, always the last phase was bound to the spaces.

Based on the building coder solution for Rooms, the workaround is to create room by phase first, and move the created room to the boundingbox of created rooms by plan circuits, then delete the wrong room, which is a method not available for spaces.

Maybe cut/ paste spaces after changing the view phase would work, but I did not test that.

Waiting for your angle on this, and hopefully a solution :slightly_smiling_face:

I haven’t contacted the orchid GitHub page, but I have tried one workaround here: from the list of phases used by linked rooms, I will select the first phase and set it to all views, then wait for this operation to complete, then create spaces in that first phase, then rerun the process. Right now, this is a long and complex workaround, so I will be hoping for a better solution from you on this.