Create Room Plans from Linked File

I am trying to produce rooms from linked file, unable to do so and encountering this message “Traceback (most recent call last):”

There might be a missed node between LinkedInstanceElements and FloorPlan.ByRoom,

Thanks!

The problem seems to be in the “Get.Document” Node. Please, post pics of the node.

hi @nainoorpatel

here’s the blow-up pics, the Room lists are being read but I’m unable to create the rooms in Revit model & receiving the notification about Traceback,

Thanks!

I JUST ran this node myself to make ~20 kitchen type plans in about 45 seconds while I checked my email, and then ran my bathrooms for the same result (thanks again @Konrad_K_Sobon!). On the bathrooms I had to re-run the script when realized I filtered my room list incorrectly, and got a similar error as you on my the second run, though all my views were still created.

So I recommend you first double check that the views aren’t hiding somewhere. If you do a new view schedule with no sorting the “newest” views are at the bottom of the list, which can help you find things.

If they aren’t there, try closing dynamo and reopening. If they still aren’t there, try removing the List.Create node. You’re technically feeding in a nested list at the moment.

If that still doesn’t work try reinstalling archi-lab to the latest/greatest version supported by your Revit version, and then try it again. If it still fails post back and I’ll have another look tomorrow (my bathroom types need to be run again anyways).

1 Like

Thanks @JacobSmall! will try your recommendations

@JacobSmall it works! removed the List.Create node + checking my views. Thanks!

Glad to hear! :smiley:

Hmmmmm… I am trying to do the same thing with zero luck. I get that same error with level id missing but its not creating the plans. I believe it is due to the levels in my model having a different levelid then the linked model. I tried to modify the node to react to the level name but that did not work. Not sure how I could modify the node to lets say match level names between links then grab the levelid from my model not the linked. Does that make sense? lol Any help is appreciated. The graph is attached, ultimately I want to filter the room list but just trying to get any plans created automatically as a starting point.

Create Views by Room.dyn (47.9 KB)

Hi Jeremy, I’m having exactly the same problem as yourself and came to the same conclusion. Did you manage to fix the code so that it matched level names rather than looked for the levelid? Any help / guidance greatly appreciated!

I ended up doing two scripts, have not been maintained in months :slight_smile:

Here they are, if you post your script I can try to help with you specific problem. I think you can do what your asking using list filter or group by key using the names as the keys.

Create Callouts by Room.dyn (85.1 KB) Create Views by Room.dyn (47.9 KB) CREATE VIEWS FROM LEVELS.dyn (66.1 KB)

1 Like

Many thanks for that!

I managed to fix it with some help from a colleague. We amended the python node by:

Feeding the level selected within the Host model to the python node (as IN[4]) and add the following line after the try statement (line 59) in python.

levelId = UnwrapElement(IN[4]).Id

Then delete line 84.

You’re far beyond me…Thanks for the help I will look into it when I am back into this realm.

Hi Thomas,

I did follow your settings adding the extra information for the host level , however, I did not have any success.

would you mind pasting here the modified python node to have a look?

Cheers

Jose

Hi @jose.cantalejo, see below. Couldn’t figure out how to paste this code correctly formatted here so I’ve uploaded a txt file.

CreatePlansFromLinkedModelRooms.txt (3.3 KB)

1 Like