Create Family from Import Symbol and Random height extrusion

revit
importinstance
geometry
nodemodel

#1

Hi Everyone

I’m trying to create some extrusions from a cad file to create a rough context, I managed to create the extrusion in Revit, but how can I import them in Revit, as Generic models/Mass? I tried with ImportIstances.by Geometry but creates only Imported symbols… I tried to link it with “ExporttoSat” and then back with “Import from SAt” but seems like it doesn’t affect anything…

I tried even with DirectShape.byGeometry but still no results. What am I doing wrong?

To get the heights of every block I’m sorting out which is best way to do it…

I placed some text tags on the plan view… How can I obtain the correspondance between the value and the boundary which is placed in? Any hints on that? Is there a command to associate an element with Polycurve boundaries?

Thanks for all your support!


#2

What’s the error on the direct shape node?

I usually use a familyinstance.bygeometry in the springs package for this.

To get the heights, you could try using a polygon containment test for the location of the text elements themselves, assuming they are all inside the building perimeter as you indicated.


#3

This was the error with the Direct shape node. I tried also with Familyinstance.bygeometry, but gives me only Import Symbols… I’d like to import them in my project as a family…

I tried the Export/Import from SAT definitions, but nothing happened.

Here is my last attempt definition, if you want to take a look at it.

definition_massing_from_extrusion.dyn (8.4 KB)

I’ll try the containment test, hope I’ll do it right


#4

I achieved to create the blocks (was something wrong with the actual mass family I was using, apparently Dynamo likes only Family template from 2013 version)…

Now I still have problem with different heights… Why does the curve.extrude to solid node not work?
Apparently I can not put into this definition an array of elements. How can I override this problem?

“Warning: One or more of the input types are not matching. Couldn’t find a version of ExtrudeAsSolid that takes arguments of type (__array,Autodesk.DesignScript.Geometry.Vector,__array)”