Corrupted Memory on a node?

Okay this is something i haven’t seen in a minute. Corrupted memory error on a oldie but goodie room centering node.
i check this post: Attempted to read or write protected memory. This is often an indication that other memory is corrupt

The result was a bug in the code, which i am in no way qualified to asses. (know your limits-ha!) trying to get something out before lunch east coast time. Any help would be awesome sauce!!

Oh wow. That is weird as heck. Never seen that with my node, but I bet I need to dispose of the temp points like you pointed out in that thread.

Can you expand your current selection node for us?

Also what Revit version and Dynamo version?

And to get you done in time for your deadline this should do. @Melissa.Stewart


I’m on Revit 2019.2
BIM 360 Job (i’m never sure if that matters sometimes)
I just updated to dynamo 2.0.3 just now that solved the room center error (I had a feeling) now i’m getting this.

This a Thursday pretending to be Monday for me.

Hmm, try being more specific with that selection. For some reason some of the room tags are returning as unique family instances :thinking:

I uploaded a new version of Rhythm. If you could give it a try that would be awesome. Version 2019.11.7

Sadly, you will have to close and reopen Revit/Dynamo. :disappointed:

Gotcha – let me download :slight_smile:

Mostly worked! I was able to get 90% of the way there, i’ll have to tinker with it more tomorrow. Something about this model and every node throws up curve errors. I have a feeling it’s all the unplaced rooms we are working through. I SUPER appreciate your help today !!:blue_heart::green_heart::blue_heart:

1 Like