Copy Revision Cloud Help

So I am trying to copy all the revision clouds from one revision to another. I am able to get all the revisions, their view and their curve geometry, but when pass that to create revision node I get an error. looks like the RevisionCloud.ByCurve node doesn’t like an array of curves, so I tried flattening the list but that didn’t seem to work either. Any thoughts?

Revsion copy.dyn (7.5 KB)

I even tried match list elements and flattening so all the inputs had the same data structure, but that still didn’t help.
Revsion copy Flatten.dyn (12.6 KB)

@Dennis_Nelson I’m not sure exactly what I did differently (maybe held my breath just right, but I took your graph and modified it. My Dynamo was freezing up when I ran it in automatic so I switched it over to manual mode and it worked just fine (must have been an infinite loop created with all of the nodes trying to auto update).

One thing that I did modify was the bool filter. With the RevisionCloud.Revision and Select Revision nodes my == node always produced false even when they were the same, so I added an Element.Id node to each result and my == node gave me the results I was expecting. I’ve attached the modified graph for you to test. I hope it helps.

Revsion copy.dyn (18.6 KB)

HI Brandon,

I tried this script that you posted and it generates an error:

What more did you do to overcome the input of multiple revision clouds?



Does this node even work? I can’t plug any kind of curve data into it that does not generate the same error. hmmmmm.

To be continued here:

Hi Cody,

I’ve been away from this one for a while so I re-downloaded the script and opened it up in a project. It still doesn’t have any issue when I run it. I looked through each node and it appears I used one node from the Clockworks package while every other node is a standard out of the box node. Do you have Clockworks installed?

Yeah I definitely do. Here’s my version of the graph:

Always get the same error.

Cody_Winchester - your script works for me. The only issue is that I’m getting blue boxes around where the copied revision cloud goes. Does anyone know how to get rid of these blue lines? They disappear when I rerun the script without the revision clouds category node attached to the all elements of category node, but always appear when I run the script with everything set up correctly. Thoughts? Thanks!!