Conflict in Archi-lab.net

There’s a Dynamo 2.0?
I’m still struggling with all the changes in 1.3!
And my entire user base is on 1.2

Dynamo 2.0 is unreleased, but the code is open source, so @Konrad_K_Sobon maybe be building his package against it.

I have more faith in Konrad than that. I doubt it’s his mistake. Much more likely mine.
The change from 1.2 to 1.3 has really tied me in knots. Somehow I got crossed versions and it’s taking a LONG time to unwind everything. I just hope this doesn’t happen when I roll 1.3 out to the office.

Idk, @Michael_Kirschner2 might be correct. I do have 2.0 on my machine and I wouldn’t be surprised if I managed to build my package against it (unknowingly). :slight_smile: I am glad it’s working for you. If I get more reports that this behavior is happening, I will investigate this to provide a fix.

Cheers!

AARGHHH!!
It’s back!
I’m getting the System.IO.FileLoadException again this morning.
I haven’t changed anything!
That line about RevitNodes. Version 2.0.0 make me think there IS something from Dynamo 2.0 in there.

The error went away yesterday, but now I’ve got two Notifications again
While loading assembly Archi-lab_Grimshaw, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null, Dynamo detected that the dependency RevitNodes, Version=2.0.0.4981, Culture=neutral, PublicKeyToken=null was already loaded with an incompatiable version.

Hi @DaveP

Uninstall archi-lab 2016.13.4 version and install 2016.13.3 which should i believe would fix your issue.

3 Likes

Getting same error:

with archi-lab 2016.13.4 installed.

Installing 2016.13.3 fixed it.

I also bumped into this problem with 2016.13.4. However, when I tried 2016.13.3 and 2016.13.2, I didn’t have any luck. I don’t get the error message for the two latter ones, but something in the packages makes all my custom functions in code blocks useless. Is there any solution on the way? I am running Dynamo 1.3.1.1736 on Revit 2017.

I am having the same issue.

https://imgur.com/a7SbwVn

same here, and not only with @Konrad_K_Sobon package…

I am working on a small update to mine that will remove the errors. Yes, that’s not the first time that I saw that. Unfortunately that happens with my other package as well - Mandrill. It has to do with things that are out of my control.

1 Like

Hi @Jean-Marc_Couffin

I have solved this similar issue for @awilliams by removing all custom packages and installing first archi-lab package. Hope it helps for you also.

3 Likes

that is what I understood. thanks for taking the time to explain and reply.

Hi @Kulkul,
the thing is that I have 10 of those errors.
Archilabs makes it 3/4, the rest by other nodes. useful ones. and I would not know in which sequence to install custom nodes again so that it works.

I hoped the 2018.2 update would solve this issue… well…

thanks

Konrad released an update (2018.0.6) this week.
I installed it and no longer see those conflicts. :+1:

1 Like

I got around it by downloading the packages online and not using the package manager through dynamo.

Hello. I have the same problem.
"archilab, Version=2018.0.0.1, Culture=neutral, PublicKeyToken=null Dynamo discovered a loaded dependency RevitAPI, Version=18.0.0.0…"
Revit 2017.2.2
Archilab 2018.0.6

These issues were fixed in the latest Archi-lab package 2018.0.7 and up.

I have 2018.08 and still get the errors so I don’t think it’s been fixed yet.

I meant 2018.0.8