Hi everyone, I can not get Civil3dtoolkit working in any way, I have updated civil3d2020.4 and Dynamo Up.2, but the result is the same, does anyone have a problem?

@p-dandrea can you download the latest version to begin with? It is loading only half of the libraries (those contained in the assembly that ends with “UI”)

Hi Paolo, the latest version 1.1.3 installed, the resiltato doesn’t change

Hi Paolo, the latest version 1.1.3 installed, the resiltato doesn’t change

I loaded the Autodesk.Civil3DToolkitUI.dll file, but nothing

Just to confirm, I’m running 2020.4 and the Toolkit loads fine.
We cleansed together the packages folder but still no luck, only one .DLL is loaded so you don’t get access to the bulk of the nodes in the Civil 3D Toolkit.
It seems logical to think that it has something to do with the installation/configuration on your machine (e.g. add-ons that might conflict competing for the same libraries in the background). Letting @Michael_Kirschner2 know, he might have some other ideas.

Hi, can you paste your dynamo log here? from under view console?

Hi, I format the pc and installed Civil3D.4 and Dynamo.2 the problem has not been solved, I attach the registry

@p-dandrea can you look at your manage package paths settings and remove any entries to dlls directly if you find them? (as opposed to entries pointing to package folders)

A post was merged into an existing topic: Civil 3D Toolkit Feedback thread

Hi Michael, sorry for the long time for the reply. I followed your instructions, I delete the paths, Civi3dToolkit installed, the result does not change, I only upload the file “Autodesk.Civil3DToolkit.dll”

I correct it loads “Autodesk.Civil3DToolkitUI.dll” but does not load “Autodesk.Civil3DToolkit.dll”

I solved moved the “Civil3dtoolkit” folder to another location and entered a new path. Thank you all.