Can´t write to parameter of a wall inside a stacked wall (read only)

Hi all. I’m trying a script to capture values from rooms and write them to it´s boundary elements. The problem is I’m using stacked walls and the parameters of the walls that are inside a stacked wall are “read only”, even the ootb ones. When I select the walls the individual elements shows but when I try to set a parameter Dynamo says they are read only.

This a small test I’ve made with 4 walls, being 3 basic walls and 1 stacked wall with 3 basic walls on it’s structure. As you can see I can set the parameters of the basic walls but not for the walls inside the stacked wall.

Does someone has a workaround to this?

Thanks in advance,
Gustavo

Hi @Gustavo_Bento_De_Me1

You need to breakup stack walls if you want to set “Comments” Parameter. It doesn’t have that parameter. Watch video below from @john_pierson. Once you breakup then your good to go to set “Comments” parameter.

1 Like

Thank you Kulkul. The problem is: I would like to keep the stacked walls, we are using them in our workflow. And I was not trying to change comments on the stacked walls, it was on the walls of it’s structure. I think it wasn’t very clear on my explanation, but when the walls are selected each wall on the stacked wall is selected and not the stacked wall as a whole. The problem is the walls that make the stacked wall up have their parameters set to read only for some reason and I can’t write to them.

I’ve tried to use the node from Beaker to select the walls and change the parameter but I got the same result. Is there a way to write to the parameters of these walls?

@Gustavo_Bento_De_Me1, if you can;t do it in Revit with the UI. More than likely you can;t do it with the API.

And unfortunately, you cannot modify the comments of stacked wall members.

Ok John, thank you for your time and for your nodes. I’ll try another way. Thank you too Kulkul.

Gustavo