Can´t change material tag type!


#1

Hello, I’m new to Dynamo and I need some help to get started. If this is addressed somewhere else please point it to me, I couldn’t find it.

I am trying to create a definition to change material tags types. Our standard uses different symbols for material tags: triangles for walls, circle for floors e square for ceilings. So i want to identify the host of the tag, test if it’s a wall (or any other category) and change the type of the tag to the appropriate one. The identification part i think I’ve already got to work. What I’m struggling with is to change the tag type! Even with a simple definition like the one below i couldn’t make it to work. If i try with a different category (I’ve tested with a parking object) this same definition works, but not with material tag.

 

 

 

 

 

 

 

 

The familyInstance.SetType node gives me only a null.

What am I doing wrong?

Thank you in advance,

Gustavo Mello


#2

Hi Gustavo,

You can also use “Change Family Type” from Archi-Lab Package. See below. Good Luck!


#3

Hi Kulkul, thank you very much for your help! I got to get it working with change family type node. but something went wrong when i tried to use a list with all tags of a certain type.

When i use the list with the single element (defined in the group) the script works, but when i use the big list, which is in use in the image above, it doesn´t. The lists looks of the same type to me, so I don’t know why I can’t get it to work. Is there something wrong in this definition?


#4

Well, i got it working with the OOTB SetParameterByName!! Still interested in knowing why doesn’t works with the Change Family Type node. If someone has a clue…


#5

Now I am filtering the host elements of the tags so i can change the tags’ types accordingly. The filter is working but when i hit run i get an serious error warning from Revit and can’t continue. Seems like dynamo loses the connection with Revit. I had to restart Revit but only to get the same error again. Someone have a idea of why this is happening? Thanks again. Don’t mind replying this, I’ve just noticed I’m trying change floors to material tag type. My bad!

Just rewired some nodes and now works!