Bumblebee Primer Format problem

Hi, I can’t figure out how conditional formatting works. Could sb point me what am I doing wrong? Excel file is closed, sheet name is valid, file exists :smiley: Thanks!


For some reason the align types require a number not a string. I hope this solves your problem.


Thanks to you I’ve found that I had older version of BB.

But it doesn’t work anyways :frowning:


You have to have an input to all the options in Text Style to get the node to work. See my example above. As you can see the Format Excel node is telling you Success!, but as you have found out it is lying to you. Plug in all the inputs and it will do what you want.


Sorry I did not notice before, but cell range should be A1:B1 not A1…B1. Also make sure excel sheet is closed when you go to run.


Thanks for explaining all of this to Tomasz. It’s much appreciated.


Yes, I understand that all of these seem a little “specific” and maybe should not be. If there are any functionality improvements, please let me know and I will try to fix them. Also, please post to GitHub as that’s the only way for me to get email notifications. Remember that this blog kind of sucks and I have no clue when people are discussing my plug-in. I am sorry.

Thanks guys, “cell range” was a typo.

It looks like only text style doesn’t work. Fill style works. Or maybe I’m blind (again :D)

Please find attached .dyn and .xlsx









I believe Excel only allows conditional formatting of cells with fill color or fill pattern. It does not change text style or border style under conditional formatting. Therefore, what you are asking of bumblebee will not work.


1 Like

judging by what is possible with the UI, I think that not all Text formatting options are possible but certain might be: Font Style, Color, Strike-through and Underline seem possible in the UI. I can check this out to make sure that the API allows these as well.

Thank you!