BB Data Node error

Hi All,
The BB data node is showing the following error.

IronPython.NewTypes.System.Object_2$2

I am new to Dynamo so forgive my lack of understanding but anyone know what could be causing this? I presume the node is not broken.

I believe my graph is setup correctly. Currently using Dynamo 2.1 with Revit 2020 and i have uninstalled and reinstalled the latest Bumblebee package 2019.2.1

…probably a stab in the dark, but I see is that the BB data node’s Python script looks for the IronPython library as follows.

pyt_path = r’C:\Program Files (x86)\IronPython 2.7\Lib’

I know nothing about Python but I can see that this directory does no exist on my pc. My first thought was that my library is missing but I find it in the following location.

C:\Program Files\Autodesk\Revit 2020\AddIns\DynamoForRevit\IronPython.StdLib.2.7.8

Whether this is related to the above error or not, my next question… do I need to download the latest IronPython 2.7 library and install seperately into the C:\Program Files (x86)\IronPython 2.7\Lib directory?

Apologies if this is all rookie stuff.

If your directory isn’t located in Program Files (x86), check the 64-bit directory without (x86), in which case you can modify the python script to instead be:
pyt_path = r'C:\Program Files\IronPython 2.7\Lib'

Hi Christian,
Thanks heaps for the reply.

I did a search on the system and the library is only installed at C:\Program Files\Autodesk\Revit 2020\AddIns\DynamoForRevit\IronPython.StdLib.2.7.8.

I could be wrong, but looks like the standard RVT 2020 installation now puts both Dynamo and the IronPython library in a different location to previous versions. My other workstation which previously had RVT2019 has the library located under C:\Program Files (x86)\IronPython 2.7\Lib plus a new one under RVT2020 add-ins. (I probably should have done a custom install)

Will any of this change the way custom nodes behave? I suppose i could change the location within the Python script each time I use a custom node… otherwise have a library installed in both locations would that be an issue?

In dynamo 2.1 the dynamo development team changed how ironpython was embedded and how it ran modules, therefore you do not need to add the sys append for python modules any more.

Therefore that line(and the line the pyt_path goes into) will need to be taken out of any python script

1 Like

Thanks for the response Brendan i should have read the Dynamo 2.1 release page.

Regarding the IronPython.NewTypes.System.Object_2$2 message. Please ignore.
Obviously i did not read the Bumblebee primer closely enough as this simply looks like intended feedback.
…such a noob

is anyone still having similar problem ? I am using

Revit 2021
2.6.1.8786 Dynamo core
2.6.1.8850 Dynamo Revit

BB Data is running null. I tried with lists and schedules both. I tried changing pyt_path line from code as well.

Update: I think I have narrowed down where the problem is. We use Ms Office on our server, its not installed in my personal windows as per se . I might be experiencing this problem because I am missing Microsoft.Office.Interop.Excel Namespace?. If that is the case, is it possible that I can access this ? ( I dont have administrator rights and its too much bureacracy to get that )