BaselineRegion.Shapes operation failed

BaselineRegion.Shapes operation failed
I can use a corridor 4-5 times for importing solids with a very simply shape. Suddenly I get this error. Even if I change back the corridor start and end or change the assembly, import will always get this error and the corridor will not work anymore. If I create a new corridor with the same properties it will work again 5 times until I get the error.
I tried everything possible but can not figure out what causes the error

I also met similar issue recently.

Apologies I missed this post, could you please share the CivilConnection log file? @reto.lechmann @RichardRen

copy the content to below

[3/2/2021 1:13:25 AM] CivilApplication.CivilApplication started…
[3/2/2021 1:13:25 AM] GetApplication started…
[3/2/2021 1:13:25 AM] GetApplication completed.
[3/2/2021 1:13:25 AM] CivilApplication.Units started…
[3/2/2021 1:13:25 AM] CivilApplication.Units completed.
[3/2/2021 1:13:25 AM] RevitUtils.DocumentTotalTransform started…
[3/2/2021 1:13:25 AM] CoordinateSystem(Origin = Point(X = 27.151, Y = 3.091, Z = 0.000), XAxis = Vector(X = 0.799, Y = -0.602, Z = 0.000, Length = 1.000), YAxis = Vector(X = 0.602, Y = 0.799, Z = 0.000, Length = 1.000), ZAxis = Vector(X = 0.000, Y = 0.000, Z = 1.000, Length = 1.000), XScaleFactor = 1.000, YScaleFactor = 1.000, ZScaleFactor = 1.000)
[3/2/2021 1:13:25 AM] RevitUtils.DocumentTotalTransform completed.
[3/2/2021 1:13:25 AM] CivilDocument.GetCorridors started…
[3/2/2021 1:13:25 AM] CivilDocument.GetCorridors completed.
[3/2/2021 1:13:42 AM] BaselineRegion.Shapes started…
[3/2/2021 1:13:42 AM] C:\Users\renx\AppData\Local\Temp\CorridorShapes.xml

however, I failed to find the corridorshapes.xml in my temporary folder.

Thanks, Have you got CivilPython working? Is Civil 3D busy with a command open when you are trying to do this?

No. I did not install CivilPython yet. I met the issue when I run civilconnection in revit. should I install civilpython firstly? when I run this script , civil 3d application is free. I just use it to open the .dwg file.

The fact that you don’t have CivilPython installed IS the issue, please read the instructions before reaching out for help.The issue @reto.lechmann was referring to is something completely different.

@reto.lechmann, if I understand correctly what you do is:

  1. Build a corridor with one assembly
  2. Read the shapes in CivilConnection to create the families
  3. Change the assembly in Civil 3D and rebuild the corridor
  4. Repeat point 2
  5. Repeat point 3 until you finish the shapes, but you cannot do it more than 5 times.

Can you confirm?

In my case, when using BaselineRegion.Shapes I get: “Warning: Sequence contains no matching element”. Thank you in advanced

Yes I confirm. I am using CivilConnection almost daily and this error happens often. CC works a couple of times and suddely this error occurs. Would be great if you could check it.
If I run the script in a new Revit file it works again

CivilConnection_temp.txt (1.0 KB)

There is an issue on the CivilPython side which means that probably you have an hanging command in Civil. Can you make sure you have a clean command line in Civil 3D?
This is not going to be solved as it is working all the times for me and with all due respect, there is no one who has used CC longer than I did :slight_smile: