ASCII code in code block


#1

Hi everyone!!!
I use the █ character in my walls types names (Alt+219)
Now id like change the walls types names using dynamo, but when i type Alt+219 a wrong character appears.
Anybody know why?

Thanks in advance


#2

Special characters are unique to the font, and are typically not supported by software platforms, and as such should be avoided. Apparently Dynamo is one such example of this but I know others are as well (datacad, indesign, email programs…).

Can you elaborate on the intended goal? That is are you adding the special character or removing it? This will help the community think up possible work arounds.


#3

If you haven’t already tried, it appears you can copy and paste the symbol into Dynamo just fine. And Dynamo certainly recognizes the character (despite not being able to produce the character via alt+291)

Edit: Out of curiosity, I tried a handful of other Alt codes, and I can’t really identify a commonality between symbols that can’t be produced by their alt code in Dynamo… but symbols that don’t work result in one (or probably more, as I didn’t try too many haha) of the following: ? = + " ¦ ) I thought maybe they were returning characters that would be used in Design Script because ¦ is an alternate form of | , but ¦¦ does not function in place of || in a Code Block. It’s a mystery :crystal_ball:


#4

Using a String node instead of a Code Block has proved to work for me in similar situations…


#5

@Yna_Db - that’s actually a good point but I still say avoid the special characters as a general rule. Nothing worse than finding your export to IFC or similar for use on the client’s software fails. Now if they requested it that’s a separate issue…