Areas and Rooms issues

Hi all

I have some scripts to transfer information from rooms to areas and vice versa.
The problem is that sometimes they work fine and when I open it again it doesn’t form the very beginning of the nodes:

I tried to freeze the area collector or disconnect some nodes and at that moment the room category works again

Hope you can put some light on this issue as I tried changing collectors for categories, collectors from different packages, no collectors at all…seems that happens when rooms and areas exist in the same script.

The version of dynamo isimage working on Revit 2019.2

Thank you very much

Try to use category by name and enter the name of category as a string that will make the name of the category as its every time you open the file

1 Like

Try to use “Get rooms by name or number” node from Genius Loci package.

I just tried that and it didn’t work.

It looks that the problem is with getting the room elements

I will try to start from scratch with Genius Loci package. I tried before Lunchbox, Rythm, Code with only Dynamo default nodes and after a while always get the same problem

Try to add Boolean “True” to “Refresh”

Seems like Element Binding issues…


Wow, that is a lot to take on the middle of the journey so I would read it carefully when I have some more time.
Thank you for the replies and I will try to update asap


While it sounds like element binding at first read, I don’t think that is the case. From what I see you’re not actually creating any elements - just setting parameter values. Your errors also appear to be coming in the gathering of data from your Revit document by the looks of it. That said I don’t really get where the problem is so I may be mis-reading this. Can you post your rvt and dyn?

1 Like

Thank you for the response, it is exactly as you say as I am only gathering data from the elements, not creating anything new.

There you have the script and the rvt file
pwa.rvt (3.6 MB)
RoomToAreas.dyn (41.0 KB)

Dynamo version:
with the following packages:

running in Revit 2019.2

Thank you
Good luck