Adding insulation -script problem ->Warning: Internal error, please report: Dereferencing a non-pointer

Hi everyone i am Pawel mep designer from Poland, i am new in dynamo and i want to get more skill. I searched for mep dynamo scripts. I watched few films about it and i choose film from Gökhan Özhim yt chanel (thank you very much for this film!!!). Link to film : Adding Insulation Type And Thickness To The Pipes Automatically With Revit&Dynamo - YouTube I wanted to build the same script and then using reverse engineering to change script for my projects :stuck_out_tongue: BUT i stuck at the end with one problem:

  1. “Warning: Internal error, please report: Dereferencing a non-pointer.” I read about other problems like this but they don’t work in my script…

I use normal revit pipes
I don’t know how to fix it. Please help :confused: I couldn’t upload files as a new user so i only put printscreens of my script in my google cloud [Insulation - Google Drive]

The last line is the same as 2 line.

Hi please connect pipe elements to the “Element” input of the Elements.SetParameterbyName node. You’ve connected the insulation as input. I hope it works when you change it.

If you have doubts on getting the pipe elements, 1. use Element Type node to select pipes
2. Connect it to All Elements of Type
3. This will fetch all the pipe elements. Now you can use this as mentioned above.


1 Like

Hi, thank you for reply. I tried to do this and nothing is change… I take pipes elements at the start of script

Now i can put a files so maybe it will be easear for you to see how the script is working.

Thanks for the additional information @pawel.kS3DHM . So far from what I can see, you first need to set the insulation type for the pipe before editing the thickness. Only when the pipes which already has an insulation defined and only the thickness needs to be changed, your program will work. To confirm this, add insulation manually to some pipes and try to run this program. It should work.

For adding insulation type, there is a node in mep over package.

You can try these steps until I use my workstation tomorrow.

Wow thanks for the quick reply @nithesh23 . I’m working on it right now and noticed a problem why the script didn’t work. At first I set the wrong type of insulation. Now works, but the yellow warning is still (but the script works). Thank you for your help. Without your suggestion to look at the elements, I would probably have been fighting it all day. Now I have to reorganize the system for selecting the type of insulation, but I think I will manage somehow.

1 Like

Great to hear @pawel.kS3DHM . If your issue is solved, pls mark this topic closed.

Many thanks,

Ok no problem but how i can do that?