Add Suffix to dimensions issue

Hello guys,
I’m having issue with “Set Suffix” Node. Basically I have hundreds of surveyed dimensions which have to be compared with Design dimensions:

As Suffix I need the value “SUR. (+ number)” if the difference is positive “SUR. (- number)” if the difference is negative. The problem is that the node “Set Suffix” seems to retrieve only the first element in the list. Is there something I’m doing wrong?

Attached the dyn file. add to suffix difference v1.dyn (21.0 KB)

Thanks in advance

Hi Flzzo.

Thanks for the .dyn. However without the outputs (as i don’t have the parameters or families you do) i can’t make much if it out. Could you add some screen grabs of the process running with the data shown?


Hi Thank you for the response.

In the first part of the script I retrieve all the value of the design dimension from the text below and transform it into integer. At the same time I retrieve the total length of the dimension which is the surveyed dimension.

in the second part the difference between the two sets of values is calculated and I set the suffix which should be as previous post.

In the last part (uncompleted still) I split the list in + and - values and try to apply them as part of the suffix. But it seems that the set suffix is getting only the first item in the list.

hi @Flzzo,

Seems to be all nulls as you have not selected a view? Wanted to see the outputs from the process, as it would help narrow down where the issue is.


here we are


Thanks for this, seems you are only changing 88 out of the 203 dimensions being pulled through your script? I tried to use your dyn to see if i could check it through but i don’t seem to have the same packages as yourself. Where are the nodes Remove from String After Character and Elements in view by category.

In your last image, your have all the nodes set to shortest lacing. Have you tried switching those back to Auto? As that might be the cause?

EDIT: I have removed those nodes to do a test and whilst the SetSuffix node is reporting nulls, it has changed all the dimensions in my view. :+1: All of my nodes were set to auto.



Hi Ben, thank for help. The fact is that my dimensions change but with all the same value! that’s the issue. I’ll try with your advice and let you know

From this i thought you meant only first element (dimension) in your list was being changed. I didn’t understand they were all changing to have the same suffix.

Using your original .dyn, i only changed the last node to shortest and it worked for me. Changed all my dims and each had the correct suffix applied.

If that doesn’t work, might have something to do with the levels in the lists? As your filter masks are level 1-3 whereas your last node is 1-2.