Add Shared parameters to some families (Orchid package)

orchid

#8

that is error number one then… the parameter must exist in you shared parameter file


#9

Mmmmmm, As I said, the shared parameter txt is clean, but when I run the script, dynamo create both parameters in the txt. That’s why I thought it wasn’t necessary


#10

I’ve created both parameters in the shared parameters txt before runing the script, and still doesn’t work as expected.

I got for one family the A parameter in Dimension (PG_GEOMETRY) as expected, but nothing about B parameter.

In the second family, I got The A & B parameters but in Others(INVALID), don’t know why.


#11

ohhh yes… thats right, I implemented that it made the parameters if they didnt exist :slight_smile:

Your problem is List level… but I found another error, so I am recoding that now… I will be back


FamilyDocument.AddSharedParameter Errors
Newbie - Why is Dynamo so tortuously painful to setup?
#12

ok thks


#13

here you go…
Add Share Parameter.dyn (10.0 KB)

I solved the problem with the extra document being send out of the “Add Shared Parameter” by taking only list zero and close those documents… All nodes replaced using only Orchid and OOTB nodes


Create Shared Parameters with the "Parameter.CreateSharedParameter" Node
Create Shared parameter from excel file
#14

Nice!

Thks!


#17

I’m having an issue trying to emulate the same Scenario.

Probably it is because I’m using Revit 2018 and Dynamo 2.0.1.5065


#18

Hi there,

I’m using Revit 2018 and Dynamo 1.3, so I guess is Dynamo.

Cheers

Manel


#19

The orchid package support any dynamo version later than 1.3.0+, that include the new 2.0.1+ range…


#20

I think the way i’m creating the list for the parameters is the root of the issue, sometimes I made it works and sometimes don’t I need to check how sensitive is Dynamo if a Node Crash, because I noticed sometimes I need to close the software and open it again or even jump the node and plugin directly to the close node becuase the families are still open in background.

Would be really helpfull if the node crash or something else the node can close the families automatic


#21

If you feed the nodes wrongly, then familydocuments will not be passed on… this will give errors since they are not being closed correctly. There is no other way around this than close Dynamo and Revit and start all over once more.

This is how it is, nothing to do about it.


#22

Hi erfajo,
i have a problem with your nodes, please see attached image,
i have download your packaged but is still not working
thanks for your help


#23

This is a migration problem… but I have made migration files, so why it don’t work is strange. However, it is easy to solve. Add the nodes once more and you are good to go. Sorry for the inconvenience.


#25

it looks like the file is missing. i have downloaded form your website the latest info… and it is still nor working.
any advise??
regards


#26

try using the executable installer --> https://github.com/erfajo/OrchidForDynamo
– and remember that Revit and Dynamo must be closed during installation.


#27

fixed!! thanks


#28

i cant understand the warning… could you help @erfajo??
i want do add the parameter in the froup “DATA”
Regards



#29

dont use lists for GroupName, Type and Group, try hover the “port” and you will see that the input does not take a list. It is only Document and ParameterName that takes lists as input!


#30

@erfajo so how do i add the rest of the information?
does not the node take the information from the txt file?