Add project parameter...returns null

Good monday all!

During this weekend I tried to solve this issue, adding shared parameter to the current document but without success so far.

Anyone knows what is wrong here? Keep getting “null” and “0 shared parameters added to the project” as you can see from the image below.

Thanks in advance :slight_smile:

I seems like you are adding a text “tr_1” to parameter with a numbertype. Try change it to Text instead of Number.

1 Like

hey @CVestesen thanks for your reply,
tr_1, tr_2, etc… are actually the parameter’s names, not the values. Anyway, I’ll tried to change it to text and the result is the same :confused:

1 Like

Ah sorry, I was too quick.

I’ll take a look at it later.

1 Like

Hi @Ernesto_Pellegrino

Did you try using OOTB node?

1 Like

thank you! :smiley:

hi @Kulkul,

Yes, just tried, and it is working, but only if the parameters do not already extist in the shared parameter file, if they exist, it will not add them to the project… I have a lots of Revit models on which I should add those parameters, but they already exist in the shared parameter file. Do you know if there is something else I could do?

thanks a lot @Kulkul

hey @Kulkul I solved the issue!!

I was looking for a solution starting from a wrong point of view xD

I just needed to create a Project Parameter, not a Shared one, anyway, shame on me, and thanks a lot for the help. Have a great day! :grin:

1 Like