Add coping only works with cross-product

Hello all,

I’m trying to create multiple structural trusses with dynamo. Everything works fine until i tried to add coping on all the diagonals with the top beam of the structural truss.

I used the familyInstance.AddCoping node from the clockwork package and it works perfect when 1 have a single truss. With some help from this topic: Multi-Coping (Apply Coping on multiple elements) for Trusses in Revit . With this hint i could add coping to multiple diagonals with 1 single top beam.

But now, for example, i have 3 trusses. So i want to add coping to 3 sets of diagonals with 3 top beams. In combination with the (like in the topic above) it doesn’t work. It only works when i flatten the familyinstance input (diagonals) and set de AddCoping node to cross-product. But then it takes way too long, especially when the number of trusses is going up to 20 or even more.

Is there a way to adjust my input in a way so it works without setting the lacing to cross-product?

Sorry in advance for my bad English :wink:

The graph below doesn’t work with multiple trusses:

Have you tried List Levels?

Where should i change the list levels? i’ve tried some things but nothing works.