3D Room Geometry

I was having problems with a Room this morning.
I found a post Marcello made & figured that might be a nice way to visualize my Room in 3D (c’mon Factory! Why not?)

Anyway, it’s a fairly large project and I only want one Room, so I changed the All Elements of Category node to a Select Model Elements.
If I wire Marcello’s original “All Elements” node (green Group) into the Element.Geometry node, it works correctly.
However, if I use a Select Elements node (blue Group), all of the created Geometry comes in 107-'6" too high.
As far as I can tell, I get the same Element IDs pumped into the Element.Geometry node.
I’m puzzled why they act differently.

3D Rooms.dyn (13.0 KB)

Upon further discovery, it looks like its not the difference between the input nodes.
The geometry comes in at different heights depending on which View is active when I run the graph.
I just happened to be in the 3D View when I ran with All Elements.
In order to select which Rooms to copy, of course, I have to be in a Floor Plan View.
I get the same results (too high) if I run the graph while in a Floor Plan View.

So my question changes to: What does ImportInstance use to determine it’s Base Level? Current Work Plane, perhaps?

The settings are propably the same as the default in the dialog box when you go to Insert > Import Cad.

It doesnt look like they add any settings, excpet the units: (the geometry is exportet to a temporary .sat file and then importet to Revit)

If you need more control, you could investigate the Document.Import method in the API: