Zero Touch Node "Failed to load library" .dll on Other Computers

Hello all,

I created a zero touch node and it is working on my computer; however, when I try to import the associated .dll on another persons computer I get this error.

Does anyone have experience with publishing .dll files and importing them on another computer?

Thank you in advance!

Make sure they are unblocked.

Find the dll in windows explorer, right click on it, open the properties, and click ‘unblock’ in the lower portion of the window.

I tried this, there was no unblock button on the other computer. Anything else it could be?

yes, even if there is no unblock button, you might still need to unblock them - use powershell or more easily, zip them with 7zip on your first computer, then use 7zip to unblock on the other machine.

alternatively, add whatever folder you are loading them to a trusted site on the other machine.

1 Like

also - are these really zero touch nodes? Or are they UI / NodeModel nodes?

Michael,

Thank you for your help. I was able to solve this problem by zipping the .dll with 7zip and extracting the .dll on the other computer. There was still no “unblock” button for the .zip file or the .dll; however, this solution still worked.

And yes, as far as I understand these would classify as zero touch nodes. I am just using a .xaml file to create a UI along with my .cs file which still performs some actions. I don’t know exactly what you are referring to when you say UI / NodeModel nodes, could you please expand on what those are?