What's New for Dynamo in Civil 3D 2022.1

Ah, I have another thing for the dev team :wink:

Since 2022.1 you can refer in a Code Block to ā€˜Document.ModelSpaceā€™, ā€˜Document.PaperSpaceā€™ and ā€˜Document.AcDocumentā€™ but all these returns null. I think someone accidentally made these visible or forgot to put functionality in it. It is only possible to point to ā€˜Document.Current.ModelSpaceā€™ and so on, even while these are not auto-completed.

FYI @StarLee

For Binding Data Storage settings, all the Dynamo and Dynamo Player behaviors are save with previous version if no setting is changed.

For Store in Drawing for Dynamo setting, this is the scenario:
Binding data is saved to .dyn by default.
When we run a script on drawing1, the binding data saved to .dyn is the relationship between node and object on the drawing1.
When we run the same script on drawing2, the binding data in .dyn is reset to the relationship between node and object on the drawing2.
It means when we run the same script on drawing1 back again, the relationship between node and object on the drawing1 is gone. New objects will be created, not update the original objects. It might be an issue.
If Store in Drawing for Dynamo setting is on, we will use the binding data saved in drawing when run script in Dynamo. For the above user case, the issue is solved.

1 Like

Translated by mods. Original post below the line.


I have a query, I have installed civil 3d 2022 and update 2022.1, but the Dynamo has not been installed. What could I do.


Original post below


Tengo una consulta, he instalado civil 3d 2022 y la actualizaciĆ³n 2022.1, pero no se ha instalado el Dynamo. Que podrĆ­a hacer.

The forum language is English. This is a requirement to make search work. Please translate all future posts accordingly. Thanks!

I have this same issue. I did a fresh install of Civil 3D with 2022.1 and dynamo is not appearing on the manage tab despite having the proper license permissions. Is anyone else having this issue.

I had the same issue, but with the 2022 install (not 2022.1). Installing 2022.1 actually fixed it! Anyway, you can get around it by doing NETLOAD for the AeccDynamo.dll file in C:\Program Files\Autodesk\AutoCAD 2022\C3D.

3 Likes

Unless it is disappeared. After 2021.1 installation I didnā€™t have Dynamo available anymore in Civil 3D 2021. If I search the Program Files folders I can only find this dll in 2020 and 2022 locations.

Thank you. You are a life saver.

1 Like