Values multiply by 60

I know there are unit issues with Dynamo and Revit, but this one is making me crazy.
The units in my Excel spread sheet flow through my Dynamo graph with no problems and I can follow them in the drop downs at every node, but when I check the properties inside of my Revit model these numbers multiply by 60 for some reason. I skimmed through 20 or 30 posts and couldn’t find a good way to convert them. Most posts revolve around measurements and not plain numbers Any thoughts here?

Thanks

i would suggest you look at getting revit lookup installed so you can interrogate the values behind the scenes, the reason behind this is to understand the factor difference between “value” and “value as string”(conversion for units)

See the following post i did a while back that helps to highlight this.

To get around the issue you can divide the value just prior to putting it into revit parameter by the factor difference which in this case is 60.

Add the following to a Code Block:
a / 60

I had tried using a DIVIDE node, but it would error out on me. I tried it in a few different locations

Thanks

try converting ‘Volume’ units between Liters and Cubicfeet :slight_smile:

By full purpose I ‘make’ the same problem in an assignment I give at Technical University of Denmark, in an attempt to learn students about SI units and Imperial Units. Below is a snip of the solution :slight_smile:

Hi @Bill_Mutert, @erfajo, @Brendan_Cassidy

Why not just Set parameter as per Project units. There is a method in Revit API (ConvertToItnernalUnits) to set that http://www.revitapidocs.com/2017.1/86d6d8b7-71ff-3768-4ffd-08969866dd62.htm thanks to @T_Pover who has already created this.
https://www.dropbox.com/s/lij2jvec77kcus9/set%20mech.gif?dl=0

1 Like

I’ll give it a shot, thanks

That works perfectly as a “manual override” but how can I automate that step?

manual override is the unit conversion…

the core of Revit is this odd numbering system used only in countries ruled by Britain… but not used in Britain. I had the impression that US got independent several hundred years ago, but apparently not :wink:

there is absolutely no logic in the imperial system, so I will vote for re-programming Revit :smiley:

…send from europe with love :heart_eyes:

@Bill_Mutert Read Excel -> Convert Excel Values to Numbers using String.ToNumber node -> Assign the number values to SetParameterAsProjectUnits. Hope it helps!

I remember some traffic about strings and numbers in another challenge I had, I will try that
Thanks

While I have your attention, I have another issue.
My testing model has TEN spaces with this parameter in it, but Dynamo is only pushing to one of them. Any thoughts here?

Nevermind, it was a LACING issue

@Bill_Mutert Some Basic rules - Always mark the topic as solved when you find solution.

How do you do that?

@Bill_Mutert Here is how to mark.

Got it
I went back through all of my posts and updated them

@Bill_Mutert Just click on one solution i think you by mistakenly clicked on solution to my reply on how to mark the post :smile:

1 Like