Updated Dynamo Now Crashing

Updated Dynamo to Dynamo Core 2.0.2.6826, Dynamo Revit 2.0.2.6833.
Now ever time I try to open a script program crashes.

Update when viewExtensins XML files are moved to temp. location script will open. What is my 9/10 tenths operator error or is it the 1/10 tenth program error?

1 Like

downgrade
i’m not a developer
it seems logical to me

To me that is just like saying “Throw news paper over it will be fine,Dig Daddy”. But I upgraded Dynamo to stay up to date with Rhythm package I want to know the reason for this error to be able to prevent it happening the future.

Can you share the logs and anything which shows in the console or error messages?

journal.0225.txt (147.3 KB) Revit journal
This the last Dynamo log:
dynamoLog_f112b510-3c5e-4ed3-8837-4e8f7ed05d93.txt (40.8 KB)
This is one script that I would run:
Foundation To Sheet.dyn (208.7 KB)

Updated:Reinstalled Revit 2019 and Dynamo 1.3 last night now Dynamo will run but all Scripts that I have been working on get this message “Error opening corrupted file: C:\Users\josh\Downloads\FOUNDATION DRIVER\Dynamo\Foundation.dyn”

Details of error :
"System.Xml.XmlException: Data at the root level is invalid. Line 1, position 1.
at System.Xml.XmlTextReaderImpl.Throw(Exception e)
at System.Xml.XmlTextReaderImpl.ParseRootLevelWhitespace()
at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
at System.Xml.XmlDocument.Load(XmlReader reader)
at System.Xml.XmlDocument.Load(String filename)
at Dynamo.Models.DynamoModel.OpenFileFromPath(String xmlPath, Boolean forceManualExecutionMode)
at Dynamo.Models.DynamoModel.ExecuteCommand(RecordableCommand command)
at Dynamo.ViewModels.DynamoViewModel.Open(Object parameters)

What did I do or not do?Foundation To Sheet.dyn (220.1 KB)

You’ve built or saved those graphs in 2.x format, so 1.x won’t open them. Either get the backup and check to see if those are 1.x, or install 2.0.2 on your system.

Also, per the old log you have several dependency conflicts with add-ins and 2.x. Disable add-ins and see if that solves your problem.

For some reason it will not update to 2.x i’ve even had graitec support try to figure it out with no luck.

That’s not how you install 2.x.

Go here: http://dynamobuilds.com

Download 2.0.2.

Install that including Dynamo for Revit.

Try from there.

@JacobSmall The Tech from Graitec and I have both downloaded from there I was just showing this to verify that it was not updated. We have also uninstalled everything and reinstalled twice with same results.

Updated: Just tried to install again still same results. But other machine in office allows to be updated from 1.3 to 2.x so thinking it might be personal.

Restart, and then confirm you only have the option for Dynamo 1.3 only. If so you’ll have to run the uninstall tool for all things Dynamo, confirm the registry is clean of all Dynamo entries, and then do a new install of 2.0.2.

Ok so have remove dynamo from system. But when I installed Dynamo 2.x it would not show in Revit ribbon unless i do a full reinstall of Revit 2019 but then it only gives me option for 1.3??

Found the Issue my user Account was only Remote Desktop Access for some reason. So it would default download to Administrator on this machine “The Boss”. Changed permissions on my user account to administrator Poof works like a charm. So it was personal. Thank you for the assistance.

@Ziese Did the clean installation work for you? I upgraded dynamo to 2.0.2 (Dynamo Core 2.0.2.6826, Dynamo Revit 2.0.2.6833) and it’s pretty much useless as of now. It just sits there saying run started even for getting properties of a single element. Let me know if that worked for you.
Could you post the Dynamo Core and Dynamo Revit version numbers after you did the uninstall and then reinstall?
I have noticed in the past that dynamo is most reliable when both of these versions are same.
Thanks