Trying to Learn Design Script - Doesn't seem to be working in 0.8.1?


#1

Forgive me for being incredibly ignorant on this topic, but I wanted to wade into learning design script within Dynamo. I’m looking at the first example from the manual in Geometry basics and I copy the text into a code block and I receive a warning: "Warning: Internal error, please report: Dereferencing a non-pointer. (3f47aacd),"and no point. Huh?

This is what the manual says:

x = 10;
y = 2.5;
z = -6;
p = Point.ByCoordinates(x, y, z);

Has there been a change in the language since this manual was produced? Am I completely stupid and miss something equally stupid? Uh, what gives. Thwarted.DynamoCodeBlockError


#2

You probably have a package installed that also has a point class, like Rhynamo.

Try Autodesk.Designscript.Geometry.Point(x,y,z)


#3

I’m still not getting anywhere. I tried your suggestion, designscript doesn’t seem to be a recognized command. I tried omitting it because the Autodesk portion seemed to be, but I’m still getting strange behavior:

DynamoCodeBlockError_02


#4

Hello Cody,

You forgot to add the point constructor at the end. Try with “Autodesk.Geometry.Point.ByCoordinates(x,y,z);” instead.


#5

Thanks, i had the same issue and couldnt understand why it doesnt work. We always need to add “Autodesk.Designscript.Geometry” in the syntax when there are similar coincidences between the packages?


#6

Eureka! Thanks Dimitar! Sorry I didn’t see your reply. The notifications from this site don’t seem to work either!