Trouble replicating a 'create view filter' definition


#1

Hi. I have replicated a definition described at this page https://dynamonodes.com/2016/08/04/create-view-filter/comment-page-1/#comment-1262, but it is not working. Can anyone here maybe see what’s wrong with it?

Here is a screenshot of my recreation. Also I added the definition file in reply below.


#2

also hereby my definition.

create view filter bakery luke johnson.dyn (8.5 KB)


#3

Hi jnoordzij

Do you already have a solution to your problem?
I’m having the same issues as shown below.

I found this toppic by “joris.vanbossche” but the solution given below didn’t solve the issue


#4

You’re inputting the parameter itself instead of the parameter name.


#5

Hi Nick,

Thanks for the reply
Changing the input to Parametername instead of the parameter itself doesn’t change anything

This blogpost (with an older version of the node) gives the example used.


#6

I just realized you’re trying to create a view filter for views… that won’t work. What are you trying to do exactly?
A view filter is a view specific filter for elements in that view. You don’t have view elements visible in a view.


#7

For example I would like to create view filters to hide sections at certain views. But no matter which category and/or parameter I choose, the node gives null as a result.

I’m unable to upload my dyn file so here’s another screenshot


#8

Sections don’t have a parameter Sheet Name. Try Referencing Sheet.


#9

No result…
Also when I select parameter name


#10

It looks like you can’t filter by Referencing Sheet. You’ll have to use another parameter, maybe by transferring the Referencing Sheet info to another parameter you can filter by.


#11

I’m a little stumped. It might be that you can’t filter sections that way through the API. You can filter by Sheet Name and Number manually but using Dynamo you get an error saying the parameter doesn’t exist.


#12

Don’t know if thats the point.
The dyn file can be received by following link. No matter which combination i try: no result.


#13

The code works. I can create a filter for Sections by View Name. You’re just using parameters that don’t apply to all elements of the category. You can see what I’m talking about if you pull the python code out of the custom node and troubleshoot the errors it returns.


#14

Hi Nick,

I did some research and found the archi-lab node “GET Bip Parameter Name”.
When i run Create filter with a parameter name it does create a filter

Don’t know why the upper version ins’t working but i’m fine for now.

Thanks for your help!


#15

Interesting. I had noticed that the parameter name wasn’t working so I tried other options as well. That’s when it started giving me errors that the parameter didn’t exist for the category. Now I’m not sure what the actual problem is, but I’m glad you got it figured out.


#16

I had to give up when I was trying to use that node. I was trying to setup view filters for selected worksets in the model. I finally used the FilterRule.ByRuleType to setup the ParameterFilterElement.ByRules Node:


#17

That’s the workflow I usually use as well.


#18

Agree. However the “FilterRule.byRuleType” Node does not work with BuiltIn parameters. That’s why i needed this node to work.