Springs.Number.ToString possibly not working in the current package

A very useful node! I don’t know why the “String from Object” node adds lots of Zeros after the decimal. This one doesn’t, it just converts however the number looks to an identical string.

However, I am not sure that it is working in the latest version. I built a script using version 110.2.0 and it worked great. When I wanted other users to execute the script, I had them install the various required packages, but it didn’t work. I narrowed it down to this node in the current version of Spring Nodes. I downgraded their packages to 110.2.0 and everything now works.

Can you show us the problem?
Everything seems to be working fine.

The first image is using Ver. 110.2.0

The next image is showing the error using the latest version:

Hmm… nodes’ titles appear gray when they are missing input that they require to run. But I just tried this node on my computer and it doesn’t require me to have an input for “digits” - the default value is null.ToString

If you don’t see “Default value : null” when you hover over the digits input try plugging in a null value.

Yeah, it looks like a “null” just means no rounding. @Steve_Fong1 can you copy the python block from the custom node into your main graph and try using it instead? Then we can look at any errors it gives you.

Also, have you tried it on a test set of numbers? What happens if you run it on a simple list of numbers like my example?

The null does work. Sorry, don’t get to Dynamo much, so I didn’t understand the fine point of the gray box. I do like the lack of rounding though, because I have rounded the data to the appropriate level prior to this.

Strange. If you wouldn’t mind trying it on the python portion itself I’d still like to see what the problem was.

Will do. One moment…

@Nick_Boyts I’m guessing it isn’t the python code that’s the problem, but the input node in the custom node doesn’t have the default value set…


@Steve_Fong1 when you hit “Edit Custom Node” on the Springs.Number.ToString node do you see the digits:int = null in your input node? If not, write that in and you won’t have to plug in a null value in future use.

That could definitely be it. I just want him to try it on the python portion cause it would return an error if there is one.

Interesting. The python node works when copied into the main script.

Yes, the null line is there.

Here it is with the python block and the actual node, side by side:

Simple Nums Dynamo

Well now it’s definitely saying it’s missing an input. Can you show what the custom node looks like when you edit it?


I modified the node a few months ago and added an extra port. You’re observing Dynamo’s default behavior, which ignores the default values for new ports. All you have to do is right-click on the port and check “Use default value” and re-save your graph:


If you drag a fresh version of the node from the library, it will not be affected by this. You will only have to fix old nodes saved in the graph.

I thought this was documented better in the numerous wikis and dictionaries, but it seems that’s not the case. This problem should hopefully disappear with the next major release of Dynamo.


Thank you everyone for your help in solving this. For those of us that are not able to use Dynamo very often these types of problems can be frustrating. Seeing how you approached figuring this out has been educational. It is great to have all of you as a support resource.

Steve Fong