Springs.ElementType.Duplicate Not Working

Hello All,
I am using the Springs Springs.ElementType.Duplicate node in order to duplicate a family type based on an Excel worksheet.But this node is not duplicate element…
What should I do?
Thank you!

I’m having no problems. Can you show the list of new names?

You have duplicate types in that sublists. Try using Flatten and use List.UniqueItems before connecting Springs.ElementTypeDuplicate node.

1 Like

Hi,this is the list of new names. %E6%96%B0%E5%90%8D%E7%A7%B01 I want to create an electromechanical system type that meets the requirements of the project.

I tried, but things didn’t get better.

I tried to expand the node and found the python script run result was empty.

Could you please drop here revit file?

has anyone been able to adress that? I have the same problem when the Springs.ElementType.Duplicate node stops working if i feed him the letters from my local language. I think it could be that is is not able to hande Unicode? Because if i feed the name without the special letters it works just fine