Space Center Point


#1

Hello,

I am trying to get the center point of spaces. I’m starting by connecting the three nodes shown in the screen shot below per an example I found. As soon as I connect Element.Geometry, Revit crashes. I tried it a couple times on two different computers. Does anyone know what might be causing it to crash? Or, is there a better way of getting the center point of a space? The dynamo file is available here for reference: Space Center Point Test

 


#2

use Element location see this http://dynamobim.org/forums/topic/element-location-not-right-place/


#3

Tried your definition, worked for me…


#4

Thank you Michal and Vikram! I tried Element.Location and it does not find any points either (See screen shot below). Could something in the model be causing it? I thought maybe there were some unplaced spaces or spaces without any height that might be causing errors, but I checked and there are no uplaced spaces or spaces without height. Any other reasons why there might be an issue with a particular model? I thought maybe it had something to do with the netowork, or the central model being on a Revit server? So, I created a small local test model, but got the same thing? Any ideas on why I can’t got space locations? I am using Revit 2015. Are there any issues with Revit 2015 and Dynamo 0.9? Thanks for any help!


#5

Use Clockwork 0.90.5,

it works fine for me

 


#6

I got it to work. I had to re-install Dynamo and re-install clockwork, then it worked. Thanks for the help!